aboutsummaryrefslogtreecommitdiff
path: root/net/pdns/patches
diff options
context:
space:
mode:
authorJames Taylor <james@jtaylor.id.au>2019-06-08 01:52:23 +1000
committerJames Taylor <james@jtaylor.id.au>2019-06-14 20:34:59 +1000
commit6320a3b9cb1ba2c9dca78c15a8e1d348bada4cde (patch)
tree4f6dfc70b6fc1561e01718ee8d5686b3785ad5c4 /net/pdns/patches
parent290e23ac61e43922ccda4e5525de2144224fb1dd (diff)
pdns: add package
Maintainer: me Compile tested: armv7l, OpenWRT SDK Run tested: armv7l Linksys WRT1900ACS, OpenWrt SNAPSHOT, r9987-655fff1571 - confirmed PowerDNS server links correctly against libraries. I'm unable to test all the backend modules as I don't have suitable backing stores set up for each. Description: PowerDNS is a versatile nameserver which supports a large number of different backends ranging from simple zonefiles to relational databases and load balancing/failover algorithms. PowerDNS tries to emphasize speed and security. This commit includes the authoritative nameserver, backends and additional tools https://www.powerdns.com/auth.html Signed-off-by: James Taylor <james@jtaylor.id.au>
Diffstat (limited to 'net/pdns/patches')
-rw-r--r--net/pdns/patches/100-lua-hpp.patch60
-rw-r--r--net/pdns/patches/200-pdns-disable-pdns.conf-dist.patch25
-rw-r--r--net/pdns/patches/300-libatomic-detect.patch34
3 files changed, 119 insertions, 0 deletions
diff --git a/net/pdns/patches/100-lua-hpp.patch b/net/pdns/patches/100-lua-hpp.patch
new file mode 100644
index 000000000..fa8ac1dad
--- /dev/null
+++ b/net/pdns/patches/100-lua-hpp.patch
@@ -0,0 +1,60 @@
+--- a/pdns/Makefile.am
++++ b/pdns/Makefile.am
+@@ -54,7 +54,8 @@
+ bindparser.h \
+ named.conf.parsertest \
+ delaypipe.hh delaypipe.cc \
+- pdns.service.in
++ pdns.service.in \
++ lua_hpp.mk
+
+ BUILT_SOURCES = \
+ bind-dnssec.schema.sqlite3.sql.h \
+@@ -109,6 +108,12 @@
+
+ endif
+
++if !HAVE_LUA_HPP
++BUILT_SOURCES += lua.hpp
++nodist_pdns_server_SOURCES = lua.hpp
++CLEANFILES += lua.hpp
++endif
++
+ EXTRA_PROGRAMS = \
+ calidns \
+ comfun \
+@@ -1303,3 +1305,7 @@
+ pdns.service \
+ pdns@.service
+ endif
++
++if !HAVE_LUA_HPP
++include lua_hpp.mk
++endif
+--- /dev/null
++++ b/pdns/lua_hpp.mk
+@@ -0,0 +1,6 @@
++lua.hpp:
++ $(AM_V_GEN)echo 'extern "C" {' > $@
++ @echo '#include "lua.h"' >> $@
++ @echo '#include "lualib.h"' >> $@
++ @echo '#include "lauxlib.h"' >> $@
++ @echo '}' >> $@
+--- a/modules/luabackend/Makefile.am
++++ b/modules/luabackend/Makefile.am
+@@ -15,5 +15,15 @@
+ slave.cc \
+ supermaster.cc
+
++if !HAVE_LUA_HPP
++BUILT_SOURCES = lua.hpp
++nodist_libluabackend_la_SOURCES = lua.hpp
++CLEANFILES = lua.hpp
++endif
++
+ libluabackend_la_LDFLAGS = -module -avoid-version
+ libluabackend_la_LIBADD = $(LUA_LIBS)
++
++if !HAVE_LUA_HPP
++include ../../pdns/lua_hpp.mk
++endif
diff --git a/net/pdns/patches/200-pdns-disable-pdns.conf-dist.patch b/net/pdns/patches/200-pdns-disable-pdns.conf-dist.patch
new file mode 100644
index 000000000..015efd7d7
--- /dev/null
+++ b/net/pdns/patches/200-pdns-disable-pdns.conf-dist.patch
@@ -0,0 +1,25 @@
+--- a/pdns/Makefile.am
++++ b/pdns/Makefile.am
+@@ -68,11 +68,9 @@
+ backends/gsql/gsqlbackend.gcda \
+ backends/gsql/gsqlbackend.gcno \
+ backends/gsql/gsqlbackend.gcov \
+- dnsmessage.pb.cc dnsmessage.pb.h \
+- pdns.conf-dist
++ dnsmessage.pb.cc dnsmessage.pb.h
+
+ noinst_SCRIPTS = pdns.init
+-sysconf_DATA = pdns.conf-dist
+
+ sbin_PROGRAMS = pdns_server
+ bin_PROGRAMS = \
+@@ -1124,9 +1122,6 @@
+ endif
+ endif
+
+-pdns.conf-dist: pdns_server
+- $(AM_V_GEN)./pdns_server --no-config --config 2>/dev/null > $@
+-
+ testrunner_SOURCES = \
+ arguments.cc \
+ auth-caches.cc auth-caches.hh \
diff --git a/net/pdns/patches/300-libatomic-detect.patch b/net/pdns/patches/300-libatomic-detect.patch
new file mode 100644
index 000000000..29881cc4f
--- /dev/null
+++ b/net/pdns/patches/300-libatomic-detect.patch
@@ -0,0 +1,34 @@
+--- a/m4/pdns_check_os.m4
++++ b/m4/pdns_check_os.m4
+@@ -35,16 +35,21 @@
+ AM_CONDITIONAL([HAVE_LINUX], [test "x$have_linux" = "xyes"])
+ AM_CONDITIONAL([HAVE_SOLARIS], [test "x$have_solaris" = "xyes"])
+
+- case "$host" in
+- mips* | powerpc-* )
+- AC_MSG_CHECKING([whether the linker accepts -latomic])
+- LDFLAGS="-latomic $LDFLAGS"
+- AC_LINK_IFELSE([m4_default([],[AC_LANG_PROGRAM()])],
+- [AC_MSG_RESULT([yes])],
+- [AC_MSG_ERROR([Unable to link against libatomic, cannot continue])]
+- )
+- ;;
+- esac
++ AC_MSG_CHECKING([whether -latomic is needed for __atomic builtins])
++ AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM([[#include <stdint.h>]],
++ [[uint64_t val = 0; __atomic_add_fetch(&val, 1, __ATOMIC_RELAXED);]]
++ )],
++ [AC_MSG_RESULT([no])],
++ [LIBS="$LIBS -latomic"
++ AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM([[#include <stdint.h>]],
++ [[uint64_t val = 0; __atomic_add_fetch(&val, 1, __ATOMIC_RELAXED);]]
++ )],
++ [AC_MSG_RESULT([yes])],
++ [AC_MSG_FAILURE([libatomic needed, but linking with -latomic failed, cannot continue])]
++ )]
++ )
+
+ AC_SUBST(THREADFLAGS)
+ AC_SUBST([DYNLINKFLAGS], [-export-dynamic])