aboutsummaryrefslogtreecommitdiff
path: root/net/ovn
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:27:01 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commite7d9c865036d7bc2ac30604e8573f25ae601aed1 (patch)
tree5efb8a25df387e8e79356447c648ecc3306176b3 /net/ovn
parent35f4ef76e0c88b690ec55f26aed072c4c5989eff (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=lto
See commit 07730ff3 "treewide: add support for "lto" in PKG_BUILD_FLAGS" on the main repository. Note: Some packages only added `-flto` to CFLAGS and not LDFLAGS. This fixes it and properly enables LTO. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'net/ovn')
-rw-r--r--net/ovn/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/ovn/Makefile b/net/ovn/Makefile
index 7c5afae92..999986f93 100644
--- a/net/ovn/Makefile
+++ b/net/ovn/Makefile
@@ -23,7 +23,7 @@ PKG_CPE_ID:=cpe:/a:openvswitch:openvswitch
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_DEPENDS+=python3/host
-PKG_BUILD_FLAGS:=no-mips16
+PKG_BUILD_FLAGS:=no-mips16 lto
PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@@ -87,7 +87,7 @@ CONFIGURE_VARS += \
ovs_cv_python3=$(HOST_PYTHON3_BIN) \
-TARGET_CFLAGS += -flto -std=gnu99
+TARGET_CFLAGS += -std=gnu99
# This is needed otherwise libtool --mode=install libovn.la will fail with
# "cannot find -lopenvswitch" when doing libtool --mode=relink. Likely this
# was caused by libovn now depends on libopenvswitch.la (installed=no) since