aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch/patches
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2018-02-28 13:22:20 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-03-06 00:29:53 +0800
commitf53d452bd1c850443dbc419e9bee228c7d415cf9 (patch)
treebdc50d6cdb9dee168815d26afc1fdaa5429a6720 /net/openvswitch/patches
parent5b56acae21340070c6b5b0d7be12c961e452648f (diff)
openvswitch: python: rework host and target dependency
Open vSwitch needs to run python on build machine to make build-time required files. python-six library is only required by the openvswitch python library on target machine, not a build dependency. We override host PYTHONPATH by overriding it in MAKE_VARS. This way we can remove 0003-override-pythonpath-via-make-vars.patch This also fixes shebang wrongly pointing to python on host Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net/openvswitch/patches')
-rw-r--r--net/openvswitch/patches/0003-override-pythonpath-via-make-vars.patch26
-rw-r--r--net/openvswitch/patches/0003-python-separate-host-target-python-for-cross-compile.patch59
2 files changed, 59 insertions, 26 deletions
diff --git a/net/openvswitch/patches/0003-override-pythonpath-via-make-vars.patch b/net/openvswitch/patches/0003-override-pythonpath-via-make-vars.patch
deleted file mode 100644
index bd1c158a6..000000000
--- a/net/openvswitch/patches/0003-override-pythonpath-via-make-vars.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index a4dd7b8..099a3c1 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -53,7 +53,7 @@ endif
- # foo/__init__.py into an (older) version with plain foo.py, since
- # foo/__init__.pyc will cause Python to ignore foo.py.
- run_python = \
-- PYTHONPATH=$(top_srcdir)/python$(psep)$$PYTHONPATH \
-+ PYTHONPATH=$(top_srcdir)/python$(psep)$(PYTHONPATH) \
- PYTHONDONTWRITEBYTECODE=yes $(PYTHON)
-
- ALL_LOCAL =
-diff --git a/Makefile.in b/Makefile.in
-index 8df66e2..98b54bf 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -1654,7 +1654,7 @@ AM_CFLAGS = -Wstrict-prototypes $(WARNING_FLAGS) $(OVS_CFLAGS) \
- # foo/__init__.py into an (older) version with plain foo.py, since
- # foo/__init__.pyc will cause Python to ignore foo.py.
- run_python = \
-- PYTHONPATH=$(top_srcdir)/python$(psep)$$PYTHONPATH \
-+ PYTHONPATH=$(top_srcdir)/python$(psep)$(PYTHONPATH) \
- PYTHONDONTWRITEBYTECODE=yes $(PYTHON)
-
-
diff --git a/net/openvswitch/patches/0003-python-separate-host-target-python-for-cross-compile.patch b/net/openvswitch/patches/0003-python-separate-host-target-python-for-cross-compile.patch
new file mode 100644
index 000000000..bef698803
--- /dev/null
+++ b/net/openvswitch/patches/0003-python-separate-host-target-python-for-cross-compile.patch
@@ -0,0 +1,59 @@
+From dd52bf474a8c03a3b7a5d73229b64971d76adafd Mon Sep 17 00:00:00 2001
+From: Yousong Zhou <yszhou4tech@gmail.com>
+Date: Wed, 28 Feb 2018 13:42:44 +0800
+Subject: [PATCH] python: separate host/target python for cross-compile
+
+At the moment, python-six is a requirement for openvswitch python
+library on target machine.
+
+Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
+---
+ Makefile.am | 2 +-
+ m4/openvswitch.m4 | 12 ++++--------
+ 2 files changed, 5 insertions(+), 9 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 31d6331..4b9e8d4 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -59,7 +59,7 @@ endif
+ # foo/__init__.pyc will cause Python to ignore foo.py.
+ run_python = \
+ PYTHONPATH=$(top_srcdir)/python$(psep)$$PYTHONPATH \
+- PYTHONDONTWRITEBYTECODE=yes $(PYTHON)
++ PYTHONDONTWRITEBYTECODE=yes $(PYTHON_HOST)
+
+ ALL_LOCAL =
+ BUILT_SOURCES =
+diff --git a/m4/openvswitch.m4 b/m4/openvswitch.m4
+index 00ffad3..52f207b 100644
+--- a/m4/openvswitch.m4
++++ b/m4/openvswitch.m4
+@@ -347,20 +347,16 @@ else:
+ if test $ovs_cv_python = no; then
+ AC_MSG_ERROR([cannot find python 2.7 or higher.])
+ fi
+- AM_MISSING_PROG([PYTHON], [python])
++ AC_SUBST([PYTHON])
+ PYTHON=$ovs_cv_python
++ AM_MISSING_PROG([PYTHON_HOST], [python])
++ PYTHON_HOST=$ovs_cv_python_host
+
+ # HAVE_PYTHON is always true. (Python has not always been a build
+ # requirement, so this variable is now obsolete.)
+ AC_SUBST([HAVE_PYTHON])
+ HAVE_PYTHON=yes
+- AM_CONDITIONAL([HAVE_PYTHON], [test "$HAVE_PYTHON" = yes])
+-
+- AC_MSG_CHECKING([whether $PYTHON has six library])
+- if ! $PYTHON -c 'import six ; six.moves.range' >&AS_MESSAGE_LOG_FD 2>&1; then
+- AC_MSG_ERROR([Missing Python six library or version too old.])
+- fi
+- AC_MSG_RESULT([yes])])
++ AM_CONDITIONAL([HAVE_PYTHON], [test "$HAVE_PYTHON" = yes])])
+
+ dnl Checks for Python 3.x, x >= 4.
+ AC_DEFUN([OVS_CHECK_PYTHON3],
+--
+1.8.3.1
+