aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch/patches
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2017-06-17 22:05:08 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2017-06-29 13:48:42 +0300
commite26a34c6b4f634240d2dd562efb8649654006b23 (patch)
tree605bf9eeaf83433f332adabea869dd01c2cb3c3e /net/openvswitch/patches
parent1359e072be2e4b368d7b1b793f487905e74903ae (diff)
openvswitch: enforce the use of the python binary from `packages`
Seems it was not failing for me because it was probably using my host Python, which may have the `six` package available. This patch enforces the use of the packaged Python. That way, it's more consistent that the python-six package is available. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'net/openvswitch/patches')
-rw-r--r--net/openvswitch/patches/0003-override-pythonpath-via-make-vars.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/openvswitch/patches/0003-override-pythonpath-via-make-vars.patch b/net/openvswitch/patches/0003-override-pythonpath-via-make-vars.patch
new file mode 100644
index 000000000..bd1c158a6
--- /dev/null
+++ b/net/openvswitch/patches/0003-override-pythonpath-via-make-vars.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile.am b/Makefile.am
+index a4dd7b8..099a3c1 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -53,7 +53,7 @@ endif
+ # foo/__init__.py into an (older) version with plain foo.py, since
+ # foo/__init__.pyc will cause Python to ignore foo.py.
+ run_python = \
+- PYTHONPATH=$(top_srcdir)/python$(psep)$$PYTHONPATH \
++ PYTHONPATH=$(top_srcdir)/python$(psep)$(PYTHONPATH) \
+ PYTHONDONTWRITEBYTECODE=yes $(PYTHON)
+
+ ALL_LOCAL =
+diff --git a/Makefile.in b/Makefile.in
+index 8df66e2..98b54bf 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1654,7 +1654,7 @@ AM_CFLAGS = -Wstrict-prototypes $(WARNING_FLAGS) $(OVS_CFLAGS) \
+ # foo/__init__.py into an (older) version with plain foo.py, since
+ # foo/__init__.pyc will cause Python to ignore foo.py.
+ run_python = \
+- PYTHONPATH=$(top_srcdir)/python$(psep)$$PYTHONPATH \
++ PYTHONPATH=$(top_srcdir)/python$(psep)$(PYTHONPATH) \
+ PYTHONDONTWRITEBYTECODE=yes $(PYTHON)
+
+