aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch/patches
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2015-12-13 21:45:20 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2015-12-13 21:50:11 +0200
commit9afb25cc5a61ff92a959b7dd883b50d3fb69cd23 (patch)
tree1ef03a653b4612c4208c24b6542c9ac3bb13a8c0 /net/openvswitch/patches
parent315ef6bf4299f4ce320b89f7753c6ade15321b19 (diff)
openvswitch: fix build with musl and GCC 5
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'net/openvswitch/patches')
-rw-r--r--net/openvswitch/patches/0004-musl-compatibility.patch26
1 files changed, 13 insertions, 13 deletions
diff --git a/net/openvswitch/patches/0004-musl-compatibility.patch b/net/openvswitch/patches/0004-musl-compatibility.patch
index 25aa45d8a..ddcc5fc61 100644
--- a/net/openvswitch/patches/0004-musl-compatibility.patch
+++ b/net/openvswitch/patches/0004-musl-compatibility.patch
@@ -1,8 +1,8 @@
diff --git a/configure.ac b/configure.ac
-index 8d47eb9..69eeed8 100644
+index e6a23a6..8a7c6d6 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -117,7 +117,6 @@ OVS_CHECK_XENSERVER_VERSION
+@@ -118,7 +118,6 @@ OVS_CHECK_XENSERVER_VERSION
OVS_CHECK_GROFF
OVS_CHECK_GNU_MAKE
OVS_CHECK_TLS
@@ -11,7 +11,7 @@ index 8d47eb9..69eeed8 100644
OVS_CHECK_ATOMIC_ALWAYS_LOCK_FREE(1)
OVS_CHECK_ATOMIC_ALWAYS_LOCK_FREE(2)
diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
-index 9b2e74f..70126bb 100644
+index 712cb5a..e840f10 100644
--- a/lib/netdev-linux.c
+++ b/lib/netdev-linux.c
@@ -40,7 +40,9 @@
@@ -25,15 +25,15 @@ index 9b2e74f..70126bb 100644
#include <netinet/in.h>
#include <poll.h>
diff --git a/lib/ovs-atomic.h b/lib/ovs-atomic.h
-index 9ead907..86d3341 100644
+index 9ead907..0a131d7 100644
--- a/lib/ovs-atomic.h
+++ b/lib/ovs-atomic.h
-@@ -325,8 +325,6 @@
- #include "ovs-atomic-clang.h"
- #elif HAVE_STDATOMIC_H
- #include "ovs-atomic-c11.h"
-- #elif __GNUC__ >= 4 && __GNUC_MINOR__ >= 7
-- #include "ovs-atomic-gcc4.7+.h"
- #elif __GNUC__ && defined(__x86_64__)
- #include "ovs-atomic-x86_64.h"
- #elif __GNUC__ && defined(__i386__)
+@@ -318,7 +318,7 @@
+ #include "util.h"
+
+ #define IN_OVS_ATOMIC_H
+- #if __CHECKER__
++ #if 1
+ /* sparse doesn't understand some GCC extensions we use. */
+ #include "ovs-atomic-pthreads.h"
+ #elif __has_extension(c_atomic)