aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-09-22 15:51:34 +0300
committerYousong Zhou <yszhou4tech@gmail.com>2021-09-23 09:15:34 +0800
commitb2bfb572a33401bd9437ce84ff53aba0da74d742 (patch)
treee357a724310505cc39f1a50e544ea5b98b8d7d5e /net/openvswitch/Makefile
parent34b06f38375bd96036effdfba53929bb18d5ce4b (diff)
openvswitch: fix build with libunbound
Due to a copy-paste error, libopenvswitch is missing a dependency when Open vSwitch is configured to use unbound: Package openvswitch-libopenvswitch is missing dependencies for the following libraries: libunbound.so.8 Use the correct config symbol to solve this. Fixes: 45c8cc9d8a7b ("openvswitch: make libunbound optional") Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'net/openvswitch/Makefile')
-rw-r--r--net/openvswitch/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index f8f99a1e6..bbe8b4614 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -17,7 +17,7 @@ include ./openvswitch.mk
#
PKG_NAME:=openvswitch
PKG_VERSION:=$(ovs_version)
-PKG_RELEASE:=7
+PKG_RELEASE:=8
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
PKG_HASH:=7d5797f2bf2449c6a266149e88f72123540f7fe7f31ad52902057ae8d8f88c38
@@ -155,7 +155,7 @@ ovs_libopenvswitch_title:=Open vSwitch (libopenvswitch.so)
ovs_libopenvswitch_hidden:=1
ovs_libopenvswitch_depends:=+libopenssl +!(arc||arceb):libunwind
ovs_libopenvswitch_depends+=+libatomic
-ifeq ($(CONFIG_KEEPALIVED_ROUTES),y)
+ifeq ($(CONFIG_OPENVSWITCH_WITH_LIBUNBOUND),y)
ovs_libopenvswitch_depends+=+libunbound
endif
ovs_libopenvswitch_files:=usr/lib/libopenvswitch*.so*