aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2020-03-25 23:04:12 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2020-03-26 15:50:34 +0800
commit88dcd094873dd9d28515cd3408077f4d5574eccb (patch)
tree661a429c2fa09487e10d99b528782d51d8f0b36f /net/openvswitch/Makefile
parent07d6310d2fb9a5e8c453bce62052c7d191817d2b (diff)
openvswitch: depend on IPV6 for intree kmods
Ref: https://github.com/openwrt/packages/issues/11665 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net/openvswitch/Makefile')
-rw-r--r--net/openvswitch/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 14231a0d9..09ff2b4a7 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -57,7 +57,7 @@ ifeq ($(if $(call ovs_kmod_is_intree,$(1)),$(ovs_kmod_intree_not_supported)),)
CATEGORY:=Kernel modules
SUBMENU:=Network Support
TITLE:=$(ovs_kmod_$(1)_title)
- DEPENDS:=$(ovs_kmod_$(1)_depends) $(if $(call ovs_kmod_is_intree,$(1)),@DEVEL)
+ DEPENDS:=$(ovs_kmod_$(1)_depends) $(if $(call ovs_kmod_is_intree,$(1)),@IPV6 @DEVEL)
PROVIDES:=$(call ovs_kmod_package_provides,$(1))
KCONFIG:=$(ovs_kmod_$(1)_kconfig)
FILES:=$(ovs_kmod_$(1)_files)