aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch/Makefile
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2021-11-08 12:06:09 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2021-11-10 14:32:16 +0200
commit2648f2e02c864c3615bf53db4a79a0d9f4d00202 (patch)
treed22322174792ab02b7572dcba647931e9807e140 /net/openvswitch/Makefile
parentb5132de5cf4f7d0562445cf3c65f9f1a4bcb1bbf (diff)
openvswitch: remove python-six dependency
Python six was required to build the OVS Python libs during the time when they were supporting both Python 2 & 3. Python 3 is a minimum requirement for OVS Python's libs since commits: https://github.com/openvswitch/ovs/commit/1ca0323e7c29dc7ef5a615c265df0460208f92de https://github.com/openvswitch/ovs/commit/bd9052455092630e03485538a29f9f8d147c41ca and Six is no longer required since commit https://github.com/openvswitch/ovs/commit/0c4d144a989a444d038d58272d8571e97e00e86f The end-goal here is to get rid of the Python Six host-build. OVS is the only user. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'net/openvswitch/Makefile')
-rw-r--r--net/openvswitch/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 1fdc11c07..d9872ba98 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -17,7 +17,7 @@ include ./openvswitch.mk
#
PKG_NAME:=openvswitch
PKG_VERSION:=$(ovs_version)
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
PKG_HASH:=7d5797f2bf2449c6a266149e88f72123540f7fe7f31ad52902057ae8d8f88c38
@@ -27,7 +27,7 @@ PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:openvswitch:openvswitch
PKG_BUILD_DIR:=$(ovs_builddir)
-PKG_BUILD_DEPENDS+=python3/host python-six/host
+PKG_BUILD_DEPENDS+=python3/host
PKG_USE_MIPS16:=0
PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
@@ -234,7 +234,7 @@ $(eval $(call OvsPackageTemplate,openvswitch))
ovs_python3_title:=Open vSwitch (Python3 library)
ovs_python3_hidden:=
-ovs_python3_depends:=+PACKAGE_openvswitch-python3:python3 +PACKAGE_openvswitch-python3:python3-six
+ovs_python3_depends:=+PACKAGE_openvswitch-python3:python3
define ovs_python3_install
$$(INSTALL_DIR) $$(1)$$(PYTHON3_PKG_DIR)
$$(CP) $$(PKG_INSTALL_DIR)/usr/share/openvswitch/python/ovs $$(1)$$(PYTHON3_PKG_DIR)