aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2020-05-20 18:52:28 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2020-05-20 23:29:44 +0800
commit1091badd8399b51abbb2ddd84dd1ff0796947d06 (patch)
tree31851d3d89f9728a1bbabd34aef5b6de6ae4f812 /net/openvswitch/Makefile
parent0b6f28856005af8bb695ec9d722211e584d170a9 (diff)
openvswitch: fix file generation in /etc/modules.d
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> Reported-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'net/openvswitch/Makefile')
-rw-r--r--net/openvswitch/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 8f14a6ae6..eb5776b49 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -17,7 +17,7 @@ include ./openvswitch.mk
#
PKG_NAME:=openvswitch
PKG_VERSION:=$(ovs_version)
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
PKG_HASH:=dd5f727427e36cab22bdeae61529d8c8fccacc53d968cfa7658f7f935ddda531
@@ -62,7 +62,7 @@ ifeq ($(if $(call ovs_kmod_is_intree,$(1)),$(ovs_kmod_intree_not_supported)),)
PROVIDES:=$(call ovs_kmod_package_provides,$(1))
KCONFIG:=$(ovs_kmod_$(1)_kconfig)
FILES:=$(ovs_kmod_$(1)_files)
- AUTOLOAD:=$(call AutoProbe,$(foreach m,$(ovs_kmod_$(1)_files),$(patsubst %.ko,%,$(basename $(m)))))
+ AUTOLOAD:=$(call AutoProbe,$(foreach m,$(ovs_kmod_$(1)_files),$(notdir $(patsubst %.ko,%,$(basename $(m))))))
endef
ovs_kmod_packages+=$(call ovs_kmod_package_name,$(1))