aboutsummaryrefslogtreecommitdiff
path: root/net/openvpn
diff options
context:
space:
mode:
authorIvan Pavlov <AuthorReflex@gmail.com>2023-08-17 22:33:09 +0300
committerIvan Pavlov <AuthorReflex@gmail.com>2023-08-18 06:17:38 +0300
commitcb8508c41bc1a8e5e6823d8d25b942ed944a572c (patch)
tree4eae1209f200c75f3eff56036968bc3f15189be0 /net/openvpn
parent3d497b2bc489cf01a65c06751c5adb8437fb58ab (diff)
openvpn: update to 2.6.6
Small bugfix release For details refer to https://github.com/OpenVPN/openvpn/blob/v2.6.6/Changes.rst Also, set depends on DCO kernel module when ENABLE_DCO flag is set. Signed-off-by: Ivan Pavlov <AuthorReflex@gmail.com>
Diffstat (limited to 'net/openvpn')
-rw-r--r--net/openvpn/Makefile7
-rw-r--r--net/openvpn/patches/101-Fix-EVP_PKEY_CTX_-compilation-with-wolfSSL.patch2
2 files changed, 5 insertions, 4 deletions
diff --git a/net/openvpn/Makefile b/net/openvpn/Makefile
index 752d38535..8f79f2b10 100644
--- a/net/openvpn/Makefile
+++ b/net/openvpn/Makefile
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openvpn
-PKG_VERSION:=2.6.5
+PKG_VERSION:=2.6.6
PKG_RELEASE:=1
PKG_SOURCE_URL:=\
https://build.openvpn.net/downloads/releases/ \
https://swupdate.openvpn.net/community/releases/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=e34efdb9a3789a760cfc91d57349dfb1e31da169c98c06cb490c6a8a015638e2
+PKG_HASH:=3b074f392818b31aa529b84f76e8b5e4ad03fca764924f46d906bceaaf421034
PKG_MAINTAINER:=Magnus Kroken <mkroken@gmail.com>
@@ -36,7 +36,8 @@ define Package/openvpn/Default
URL:=http://openvpn.net
SUBMENU:=VPN
MENU:=1
- DEPENDS:=+kmod-tun +libcap-ng +OPENVPN_$(1)_ENABLE_LZO:liblzo +OPENVPN_$(1)_ENABLE_LZ4:liblz4 +OPENVPN_$(1)_ENABLE_IPROUTE2:ip +OPENVPN_$(1)_ENABLE_DCO:libnl-genl $(3)
+ DEPENDS:=+kmod-tun +libcap-ng +OPENVPN_$(1)_ENABLE_LZO:liblzo +OPENVPN_$(1)_ENABLE_LZ4:liblz4 +OPENVPN_$(1)_ENABLE_IPROUTE2:ip \
+ +OPENVPN_$(1)_ENABLE_DCO:libnl-genl +OPENVPN_$(1)_ENABLE_DCO:kmod-ovpn-dco-v2 $(3)
VARIANT:=$(1)
PROVIDES:=openvpn openvpn-crypto
endef
diff --git a/net/openvpn/patches/101-Fix-EVP_PKEY_CTX_-compilation-with-wolfSSL.patch b/net/openvpn/patches/101-Fix-EVP_PKEY_CTX_-compilation-with-wolfSSL.patch
index 81c09c1e8..0a45ea49e 100644
--- a/net/openvpn/patches/101-Fix-EVP_PKEY_CTX_-compilation-with-wolfSSL.patch
+++ b/net/openvpn/patches/101-Fix-EVP_PKEY_CTX_-compilation-with-wolfSSL.patch
@@ -9,7 +9,7 @@
#include <openssl/kdf.h>
#endif
#if OPENSSL_VERSION_NUMBER >= 0x30000000L
-@@ -1419,7 +1419,7 @@ engine_load_key(const char *file, SSL_CT
+@@ -1436,7 +1436,7 @@ engine_load_key(const char *file, SSL_CT
#endif /* if HAVE_OPENSSL_ENGINE */
}