aboutsummaryrefslogtreecommitdiff
path: root/net/openconnect
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2020-08-27 12:13:56 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2020-08-27 13:59:52 +0800
commit3445e1b4702cce97b89d76cfa7db1b1d06934faa (patch)
tree8c65e8d91fe915206450a07cdff8976ebd81a05b /net/openconnect
parentfce2b069df766646798d1bac4ccd69d0d44b9d0c (diff)
openconnect: allow disable dtls with bool option no_dtls
openconnect may emit following error logs every minute when negotiating with deployments forbidding usage of dtls Thu Aug 27 04:11:59 2020 daemon.notice openconnect[12024]: DTLS handshake failed: Error in the push function. Thu Aug 27 04:11:59 2020 daemon.notice openconnect[12024]: (Is a firewall preventing you from sending UDP packets?) Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net/openconnect')
-rw-r--r--net/openconnect/Makefile2
-rwxr-xr-xnet/openconnect/files/openconnect.sh3
2 files changed, 4 insertions, 1 deletions
diff --git a/net/openconnect/Makefile b/net/openconnect/Makefile
index 73bb315ed..36ec25f3f 100644
--- a/net/openconnect/Makefile
+++ b/net/openconnect/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openconnect
PKG_VERSION:=8.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/openconnect/
diff --git a/net/openconnect/files/openconnect.sh b/net/openconnect/files/openconnect.sh
index 97d90cb72..aef13a3c3 100755
--- a/net/openconnect/files/openconnect.sh
+++ b/net/openconnect/files/openconnect.sh
@@ -15,6 +15,7 @@ proto_openconnect_init_config() {
proto_config_add_int "port"
proto_config_add_int "mtu"
proto_config_add_int "juniper"
+ proto_config_add_boolean "no_dtls"
proto_config_add_string "interface"
proto_config_add_string "username"
proto_config_add_string "serverhash"
@@ -46,6 +47,7 @@ proto_openconnect_setup() {
interface \
juniper \
mtu \
+ no_dtls \
os \
password \
password2 \
@@ -72,6 +74,7 @@ proto_openconnect_setup() {
[ -n "$port" ] && port=":$port"
append_args "$server$port" -i "$ifname" --non-inter --syslog --script /lib/netifd/vpnc-script
+ [ "$no_dtls" = 1 ] && append_args --no-dtls
[ -n "$mtu" ] && append_args --mtu "$mtu"
# migrate to standard config files