aboutsummaryrefslogtreecommitdiff
path: root/net/openconnect
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-05-19 11:41:44 +0200
committerJo-Philipp Wich <jo@mein.io>2016-05-19 11:41:44 +0200
commit06d9094348ce912bd3989cae2ea43ec836d5ea05 (patch)
treec1ea672eb6d7e521fa038b344b487121e33360b6 /net/openconnect
parentba451bd8aab15d2be0ca0d53ff064e4ef5ce4318 (diff)
openconnect: avoid possible implicit dependency on liblz4
If the liblz4 library exists within the build environment, the openconnect configure will pick it up and start depending on it, leading to the following build error: Package openconnect is missing dependencies for the following libraries: liblz4.so.1 Disable LZ4 support in configure in order to avoid this implicit, nondeterministic dependency. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'net/openconnect')
-rw-r--r--net/openconnect/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/openconnect/Makefile b/net/openconnect/Makefile
index 33f107861..40000a883 100644
--- a/net/openconnect/Makefile
+++ b/net/openconnect/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openconnect
PKG_VERSION:=7.06
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -50,7 +50,8 @@ CONFIGURE_ARGS += \
--disable-shared \
--with-vpnc-script=/lib/netifd/vpnc-script \
--without-libpcsclite \
- --without-stoken
+ --without-stoken \
+ --without-lz4
ifeq ($(CONFIG_OPENCONNECT_OPENSSL),y)
CONFIGURE_ARGS += \