aboutsummaryrefslogtreecommitdiff
path: root/net/open-iscsi
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-10 14:26:23 -0700
committerRosen Penev <rosenp@gmail.com>2020-08-10 15:53:58 -0700
commit0c0f6f450d1e94ec7433974a10c55ff13c0dd456 (patch)
tree96f8c9a7adc69535867e5b9e8c28037f7d12ed65 /net/open-iscsi
parent8fa65a875498fa1e4c0a79dde3ac4059b7d26e8c (diff)
open-iscsi: fix compilation with musl 1.2.0
GLOB_ONLYDIR is not defined. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/open-iscsi')
-rw-r--r--net/open-iscsi/Makefile2
-rw-r--r--net/open-iscsi/patches/0004-idbw_rec_write-pick-tpgt-from-existing-record.patch17
2 files changed, 14 insertions, 5 deletions
diff --git a/net/open-iscsi/Makefile b/net/open-iscsi/Makefile
index 23cb364ca..ccb4703e3 100644
--- a/net/open-iscsi/Makefile
+++ b/net/open-iscsi/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=open-iscsi
PKG_VERSION:=2.1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/open-iscsi/open-iscsi/tar.gz/$(PKG_VERSION)?
diff --git a/net/open-iscsi/patches/0004-idbw_rec_write-pick-tpgt-from-existing-record.patch b/net/open-iscsi/patches/0004-idbw_rec_write-pick-tpgt-from-existing-record.patch
index 41436fb7f..10d9a668f 100644
--- a/net/open-iscsi/patches/0004-idbw_rec_write-pick-tpgt-from-existing-record.patch
+++ b/net/open-iscsi/patches/0004-idbw_rec_write-pick-tpgt-from-existing-record.patch
@@ -23,7 +23,18 @@ index b6193e7..2208c4a 100644
#include <sys/stat.h>
#include <sys/file.h>
#include <inttypes.h>
-@@ -202,6 +203,8 @@ static struct int_list_tbl {
+@@ -44,6 +45,10 @@
+ #include "fw_context.h"
+ #include "iscsi_err.h"
+
++#ifndef GLOB_ONLYDIR
++#define GLOB_ONLYDIR 0x100
++#endif
++
+ #define IDBM_HIDE 0 /* Hide parameter when print. */
+ #define IDBM_SHOW 1 /* Show parameter when print. */
+ #define IDBM_MASKED 2 /* Show "stars" instead of real value when print */
+@@ -202,6 +207,8 @@ static struct int_list_tbl {
{ "SHA3-256", AUTH_CHAP_ALG_SHA3_256 },
};
@@ -32,7 +43,7 @@ index b6193e7..2208c4a 100644
static void
idbm_recinfo_discovery(discovery_rec_t *r, recinfo_t *ri)
{
-@@ -2206,12 +2209,49 @@ static int idbm_rec_write_old(node_rec_t *rec)
+@@ -2206,12 +2213,49 @@ static int idbm_rec_write_old(node_rec_t *rec)
FILE *f;
char *portal;
int rc = 0;
@@ -82,6 +93,4 @@ index b6193e7..2208c4a 100644
snprintf(portal, PATH_MAX, "%s/%s/%s,%d", NODE_CONFIG_DIR,
rec->name, rec->conn[0].address, rec->conn[0].port);
---
-2.21.1