aboutsummaryrefslogtreecommitdiff
path: root/net/ola
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-06-21 11:55:02 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-06-21 11:55:02 +0200
commitc10b5a3ff739f8590573c0b6c3aeba2c27efc385 (patch)
treee741957f34463036fabe27468f5748b38ca9790d /net/ola
parentabdbf50221d3052dd8c2372c09c9e5079f11a18b (diff)
ola: implement Host/Install for ola_protoc_plugin
Should fix build with SDK on buildbots. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'net/ola')
-rw-r--r--net/ola/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/ola/Makefile b/net/ola/Makefile
index 75016d083..ec84724c8 100644
--- a/net/ola/Makefile
+++ b/net/ola/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ola
PKG_VERSION:=0.10.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/OpenLightingProject/ola.git
@@ -54,7 +54,7 @@ CONFIGURE_ARGS += \
--disable-unittests \
--disable-http \
--without-dns-sd \
- --with-ola-protoc-plugin=$(HOST_BUILD_DIR)/protoc/ola_protoc_plugin
+ --with-ola-protoc-plugin=$(STAGING_DIR_HOSTPKG)/bin/ola_protoc_plugin
HOST_CONFIGURE_ARGS += \
--disable-all-plugins \
@@ -75,8 +75,9 @@ define Host/Compile
$(MAKE) protoc/ola_protoc_plugin
endef
-# nothing to install for host part
define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/bin
+ $(CP) $(HOST_BUILD_DIR)/protoc/ola_protoc_plugin $(STAGING_DIR_HOSTPKG)/bin
endef