aboutsummaryrefslogtreecommitdiff
path: root/net/obfs4proxy/Makefile
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2019-02-01 21:56:35 +0100
committerJan Pavlinec <jan.pavlinec@nic.cz>2019-02-10 01:00:27 +0100
commitf22d1133584f97379dd10e5bd9a7ec112ebdb5c0 (patch)
tree99f6e645aac6b82a2bd93ce3d4851994a6abd86d /net/obfs4proxy/Makefile
parent4e3b866ed87c7dde8d9dd0d366e631efffbb59de (diff)
obfs4proxy: update to version 0.0.9
Changes: -remove old patch(part of 0.0.9 release) -change the canonical upstream repo location to gitlab -change source to gitlab -change source package to golang-gitlab-yawning-obfs4-dev Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'net/obfs4proxy/Makefile')
-rw-r--r--net/obfs4proxy/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/net/obfs4proxy/Makefile b/net/obfs4proxy/Makefile
index 0fc60f17d..699de9aea 100644
--- a/net/obfs4proxy/Makefile
+++ b/net/obfs4proxy/Makefile
@@ -8,14 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=obfs4proxy
-PKG_VERSION:=0.0.7
+PKG_VERSION:=0.0.9
PKG_RELEASE:=1
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://git.torproject.org/pluggable-transports/obfs4.git
-PKG_SOURCE_VERSION:=8256fac93c2cf79742725e3aaced5bbe3380fd32
-PKG_SOURCE_DATE:=20161115
-PKG_MIRROR_HASH:=9c504337f7a2b46310083224cf0998fc7645f8af5d50657cf74358d39916eddc
+PKG_SOURCE:=obfs4-$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://gitlab.com/yawning/obfs4/-/archive/$(PKG_NAME)-$(PKG_VERSION)/
+PKG_HASH:=ab2608014fae15b4e0dad2f8128e81f912ab27277539004b759180c1fb5007dd
+PKG_BUILD_DIR:=$(BUILD_DIR)/obfs4-$(PKG_NAME)-$(PKG_VERSION)
PKG_LICENSE:=BSD-2-Clause
PKG_LICENSE_FILES:=LICENSE
@@ -25,14 +24,14 @@ PKG_BUILD_DEPENDS:=golang/host
PKG_BUILD_PARALLEL:=1
PKG_USE_MIPS16:=0
-GO_PKG:=git.torproject.org/pluggable-transports/obfs4.git
+GO_PKG:=gitlab.com/yawning/obfs4.git
include $(INCLUDE_DIR)/package.mk
include ../../lang/golang/golang-package.mk
define Package/obfs4proxy/Default
TITLE:=A Tor pluggable transport proxy, implementing obfs4
- URL:=https://gitweb.torproject.org/pluggable-transports/obfs4.git/
+ URL:=https://gitlab.com/yawning/obfs4
DEPENDS:=$(GO_ARCH_DEPENDS)
endef
@@ -42,7 +41,7 @@ $(call Package/obfs4proxy/Default)
CATEGORY:=Network
endef
-define Package/golang-torproject-pluggable-transports-obfs4-dev
+define Package/golang-gitlab-yawning-obfs4-dev
$(call Package/obfs4proxy/Default)
$(call GoPackage/GoSubMenu)
TITLE+= (source files)
@@ -76,7 +75,7 @@ This package contains both the client and the bridge in a single
program.
endef
-define Package/golang-torproject-pluggable-transports-obfs4-dev/description
+define Package/golang-gitlab-yawning-obfs4-dev/description
$(call Package/obfs4proxy/Default/description)
This package provides the source files for the client/bridge program.
@@ -84,6 +83,5 @@ endef
$(eval $(call GoBinPackage,obfs4proxy))
$(eval $(call BuildPackage,obfs4proxy))
-
-$(eval $(call GoSrcPackage,golang-torproject-pluggable-transports-obfs4-dev))
-$(eval $(call BuildPackage,golang-torproject-pluggable-transports-obfs4-dev))
+$(eval $(call GoSrcPackage,golang-gitlab-yawning-obfs4-dev))
+$(eval $(call BuildPackage,golang-gitlab-yawning-obfs4-dev))