aboutsummaryrefslogtreecommitdiff
path: root/net/nut
diff options
context:
space:
mode:
authorDaniel Dickinson <lede@cshore.thecshore.com>2017-01-11 18:54:29 -0500
committerDaniel Dickinson <lede@cshore.thecshore.com>2017-01-11 18:54:29 -0500
commit5503dac80676b858f81855610170796247a86830 (patch)
tree49d2f96c1e898cd12727f40ca6a36a6ab44e6564 /net/nut
parentc1d26bacdff1dc104f59ecd06d777286fabf9c6f (diff)
net/nut: Add back serial support
It looks like serial support was accidentally dropped due to missing pieces on Config.in and Makefile. Add back serial support by fixing that. Signed-off-by: Daniel Dickinson <lede@cshore.thecshore.com>
Diffstat (limited to 'net/nut')
-rw-r--r--net/nut/Config.in7
-rw-r--r--net/nut/Makefile3
2 files changed, 10 insertions, 0 deletions
diff --git a/net/nut/Config.in b/net/nut/Config.in
index a5f1ff4be..b7f403b78 100644
--- a/net/nut/Config.in
+++ b/net/nut/Config.in
@@ -23,3 +23,10 @@
help
If you have a UPS you can connect to via SNMP, select this.
default n
+
+ config NUT_DRIVER_SERIAL
+ depends on PACKAGE_nut
+ bool "Build with suport for serial drivers"
+ help
+ If you have a UPS connected via serial cable, select this.
+ default n
diff --git a/net/nut/Makefile b/net/nut/Makefile
index a5773f1f8..25d93c48d 100644
--- a/net/nut/Makefile
+++ b/net/nut/Makefile
@@ -24,6 +24,7 @@ PKG_INSTALL:=1
PKG_CONFIG_DEPENDS:= \
CONFIG_NUT_DRIVER_SNMP \
CONFIG_NUT_DRIVER_USB \
+ CONFIG_NUT_DRIVER_SERIAL \
CONFIG_NUT_SSL
include $(INCLUDE_DIR)/package.mk
@@ -323,6 +324,7 @@ define DriverPackage
DEPENDS:=nut +nut-common
$(if $(filter $(1),snmp),DEPENDS+= @NUT_DRIVER_SNMP)
$(if $(filter $(1),usb),DEPENDS+= @NUT_DRIVER_USB)
+ $(if $(filter $(1),serial),DEPENDS+= @NUT_DRIVER_SERIAL)
endef
# Deliberately empty description in order to trigger a build failure.
# It should be overridden by the list below, and when updating to a
@@ -478,6 +480,7 @@ CONFIGURE_ARGS += \
--$(if $(CONFIG_NUT_DRIVER_USB),with,without)-usb \
--without-avahi \
--$(if $(CONFIG_NUT_DRIVER_SNMP),with,without)-snmp \
+ --$(if $(CONFIG_NUT_DRIVER_SERAL),with,without)-serial \
--without-neon \
--without-powerman \
--with-cgi \