aboutsummaryrefslogtreecommitdiff
path: root/net/nut/Makefile
diff options
context:
space:
mode:
authorDaniel F. Dickinson <cshored@thecshore.com>2018-08-20 20:06:31 -0400
committerDaniel F. Dickinson <cshored@thecshore.com>2018-08-28 15:19:39 -0400
commit5790053eba52c671465d3db6137fff265bcfb8a7 (patch)
treebf2b0d21816663ebde5cec59dc4444119e8becc0 /net/nut/Makefile
parent864fd2bfee14d4decf8c1db03380a3d7aa080f15 (diff)
nut: Add missing conffiles
We want to include the symlinks to the generated configurations in conffiles so that if the user replaces them symlinks with traditional NUT configuration it is preserved across sysupgrade. Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
Diffstat (limited to 'net/nut/Makefile')
-rw-r--r--net/nut/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net/nut/Makefile b/net/nut/Makefile
index 2a253f8c0..640d7a595 100644
--- a/net/nut/Makefile
+++ b/net/nut/Makefile
@@ -75,7 +75,6 @@ define Package/nut-server/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/nut/driver.list $(1)/usr/share/nut/
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) ./files/nut_server $(1)/etc/config/nut_server
- ln -sf /var/etc/nut/nut.conf $(1)/etc/nut/nut.conf
ln -sf /var/etc/nut/ups.conf $(1)/etc/nut/ups.conf
ln -sf /var/etc/nut/upsd.users $(1)/etc/nut/upsd.users
ln -sf /var/etc/nut/upsd.conf $(1)/etc/nut/upsd.conf
@@ -96,6 +95,10 @@ $(call Package/nut/description/Default)
This package contains the common files.
endef
+define Package/nut-common/conffiles
+/etc/nut/nut.conf
+endef
+
define Package/nut-common/install
$(INSTALL_DIR) $(1)/etc/nut
$(INSTALL_DIR) $(1)/usr/lib
@@ -120,6 +123,9 @@ endef
define Package/nut-server/conffiles
/etc/config/nut_server
+/etc/nut/ups.conf
+/etc/nut/upsd.conf
+/etc/nut/upsd.users
endef
define Package/nut-upsmon
@@ -141,6 +147,7 @@ endef
define Package/nut-upsmon/conffiles
/etc/config/nut_monitor
+/etc/nut/upsmon.conf
endef
define Package/nut-upsmon/install