aboutsummaryrefslogtreecommitdiff
path: root/net/nut/Makefile
diff options
context:
space:
mode:
authorDaniel F. Dickinson <cshored@thecshore.com>2018-08-27 16:10:48 -0400
committerDaniel F. Dickinson <cshored@thecshore.com>2018-08-29 00:15:18 -0400
commit2fca922cf0bd2d78b28a1d8a5b5b407aa61d2679 (patch)
tree55dd9f73aecdb6b2693a90ccf457656190d2ab21 /net/nut/Makefile
parent918a62f91940a3e4b11a009442d8f085bf26075a (diff)
nut: nut-cgi: Add support for upsset
This allows config for setting variables and/or running commands from the CGI. Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
Diffstat (limited to 'net/nut/Makefile')
-rw-r--r--net/nut/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/nut/Makefile b/net/nut/Makefile
index 9c18b6105..a07921686 100644
--- a/net/nut/Makefile
+++ b/net/nut/Makefile
@@ -329,12 +329,15 @@ define Package/nut-web-cgi/install
$(INSTALL_CONF) ./files/add_nut_httpd_conf $(1)/etc/uci-defaults/add_nut_httpd_conf
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/nut/upsstats.html.sample $(1)/etc/nut/upsstats.html
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/nut/upsstats-single.html.sample $(1)/etc/nut/upsstats-single.html
- $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/nut/upsset.conf.sample $(1)/etc/nut/upsset.conf
+ $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/nut/upsset.conf.sample $(1)/etc/nut/upsset.conf.disable
+ $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/nut/upsset.conf.sample $(1)/etc/nut/upsset.conf.enable
+ $(SED) 's/### \?//' $(1)/etc/nut/upsset.conf.enable
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) ./files/nut_cgi $(1)/etc/config/nut_cgi
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/nut-cgi.init $(1)/etc/init.d/nut-cgi
ln -sf /var/etc/nut/hosts.conf $(1)/etc/nut/hosts.conf
+ ln -sf /var/etc/nut/upsset.conf $(1)/etc/nut/upsset.conf
endef
define Package/nut-avahi-service