aboutsummaryrefslogtreecommitdiff
path: root/net/nut/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2014-10-25 09:31:18 +0200
committerNicolas Thill <nico@openwrt.org>2014-10-25 09:40:56 +0200
commit0d93cb8973b8909074ee67b436d44fe08b0879a9 (patch)
treeff95db91da8e1414b2340753e1fddfc0d398ac1d /net/nut/Makefile
parent896b23e650604dbac50b3d39998c2e4784e4002c (diff)
nut: force rebuild when config changes
Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'net/nut/Makefile')
-rw-r--r--net/nut/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/net/nut/Makefile b/net/nut/Makefile
index a0125c487..d23b7cb5d 100644
--- a/net/nut/Makefile
+++ b/net/nut/Makefile
@@ -21,6 +21,19 @@ PKG_LICENSE_FILES:=LICENSE-GPL2
PKG_BUILD_DIR:=$(BUILD_DIR)/nut-$(PKG_VERSION)
PKG_INSTALL:=1
+PKG_CONFIG_DEPENDS:= \
+ CONFIG_NUT_CLIENTS_UPSC \
+ CONFIG_NUT_CLIENTS_UPSCMD \
+ CONFIG_NUT_CLIENTS_UPSLOG \
+ CONFIG_NUT_CLIENTS_UPSMON \
+ CONFIG_NUT_CLIENTS_UPSRW \
+ CONFIG_NUT_CLIENTS_UPSSCHED \
+ CONFIG_NUT_DRIVER_SERIAL \
+ CONFIG_NUT_DRIVER_SNMP \
+ CONFIG_NUT_DRIVER_USB \
+ CONFIG_NUT_SERVER \
+ CONFIG_NUT_SSL \
+
include $(INCLUDE_DIR)/package.mk
define Package/nut/Default