aboutsummaryrefslogtreecommitdiff
path: root/net/ntpd
diff options
context:
space:
mode:
authorKenneth J. Miller <ken@miller.ec>2019-11-07 18:42:11 +0100
committerRosen Penev <rosenp@gmail.com>2020-09-18 02:49:10 -0700
commit3c21c392e546f2cf2aa46f28f383470daa493caf (patch)
tree8926c62188aea88487a956c9bc8e1cbc3678a07d /net/ntpd
parenta672ca3216ba90ceac833e73b9acd73dd40db5f5 (diff)
ntpd: Include sntp binary only with ntp-utils
Don't build the sntp binary and libevent2-pthread dependency unless ntp-utils is selected. Re-add ntp-keygen dependency libevent2-core. Fixes openwrt#10307 Signed-off-by: Kenneth J. Miller <ken@miller.ec>
Diffstat (limited to 'net/ntpd')
-rw-r--r--net/ntpd/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net/ntpd/Makefile b/net/ntpd/Makefile
index ff82af24c..28be8b501 100644
--- a/net/ntpd/Makefile
+++ b/net/ntpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ntp
PKG_VERSION:=4.2.8p15
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
@@ -33,7 +33,7 @@ define Package/ntpd/Default
TITLE:=ISC ntp
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
URL:=http://www.ntp.org/
- DEPENDS:=+libopenssl +libpthread +libcap +libevent2-pthreads
+ DEPENDS:=+libopenssl +libpthread +libcap
endef
define Package/ntpd/Default/description
@@ -69,17 +69,19 @@ endef
define Package/ntp-utils
$(call Package/ntpd/Default)
TITLE+= utilities
+ DEPENDS+= +libevent2-pthreads
endef
define Package/ntp-utils/description
$(call Package/ntpd/Default/description)
.
- This package contains ntpdc, ntpq and ntptime.
+ This package contains ntpdc, ntpq, ntptime and sntp.
endef
define Package/ntp-keygen
$(call Package/ntpd/Default)
TITLE+=keygen
+ DEPENDS+= +libevent2-core
endef
define Package/ntp-keygen/description
@@ -107,6 +109,7 @@ CONFIGURE_ARGS += \
--enable-linuxcaps \
--with-yielding-select=yes \
--with-crypto \
+ $(if $(CONFIG_PACKAGE_ntp-utils),--with-sntp,--without-sntp) \
--with-openssl-incdir="$(STAGING_DIR)/usr/include" \
--with-openssl-libdir="$(STAGING_DIR)/usr/lib"
@@ -145,6 +148,7 @@ define Package/ntp-utils/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpdc/ntpdc $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpq/ntpq $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/util/ntptime $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/sntp/sntp $(1)/usr/sbin/
endef
define Package/ntp-keygen/install