aboutsummaryrefslogtreecommitdiff
path: root/net/nginx
diff options
context:
space:
mode:
authorDirk Feytons <dirk.feytons@gmail.com>2016-05-09 18:09:41 +0200
committerDirk Feytons <dirk.feytons@gmail.com>2016-05-10 11:42:34 +0200
commit55ab8ffc5f7bc926397c4bf9f5cfe82201424144 (patch)
tree665b2d77af29c0e7d8c18c1e192074e5c23424bb /net/nginx
parentdc08dfbaf90ea7f6aad1c6fc4453abaf72d9a345 (diff)
nginx: correct f3c7cc6
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com>
Diffstat (limited to 'net/nginx')
-rw-r--r--net/nginx/Config.in2
-rw-r--r--net/nginx/Makefile32
-rw-r--r--net/nginx/patches-lua-nginx/100-dont_export_symbols.patch65
-rw-r--r--net/nginx/patches-lua-nginx/100-no_by_lua_block.patch (renamed from net/nginx/patches-lua-nginx/101-no_by_lua_block.patch)79
4 files changed, 69 insertions, 109 deletions
diff --git a/net/nginx/Config.in b/net/nginx/Config.in
index 349f69315..bf6b834c2 100644
--- a/net/nginx/Config.in
+++ b/net/nginx/Config.in
@@ -177,7 +177,7 @@ config NGINX_NAXSI
prompt "Enable NAXSI module"
default y
-config NGINX_MODULE_LUA
+config NGINX_LUA
bool
prompt "Enable Lua module"
default n
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index c4e9f0b56..af0747636 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -56,7 +56,7 @@ PKG_CONFIG_DEPENDS := \
CONFIG_NGINX_HTTP_CACHE \
CONFIG_NGINX_PCRE \
CONFIG_NGINX_NAXSI \
- CONFIG_NGINX_MODULE_LUA
+ CONFIG_NGINX_LUA
include $(INCLUDE_DIR)/package.mk
@@ -66,7 +66,7 @@ define Package/nginx
SUBMENU:=Web Servers/Proxies
TITLE:=Nginx web server
URL:=http://nginx.org/
- DEPENDS:=+NGINX_PCRE:libpcre +(NGINX_SSL||NGINX_HTTP_CACHE||NGINX_HTTP_AUTH_BASIC):libopenssl +NGINX_HTTP_GZIP:zlib +NGINX_MODULE_LUA:liblua +libpthread
+ DEPENDS:=+NGINX_PCRE:libpcre +(NGINX_SSL||NGINX_HTTP_CACHE||NGINX_HTTP_AUTH_BASIC):libopenssl +NGINX_HTTP_GZIP:zlib +NGINX_LUA:liblua +libpthread
MENU:=1
endef
@@ -192,12 +192,6 @@ endif
ifneq ($(CONFIG_NGINX_HTTP_UPSTREAM_KEEPALIVE),y)
ADDITIONAL_MODULES += --without-http_upstream_keepalive_module
endif
-ifeq ($(CONFIG_NGINX_MODULE_LUA),y)
- ADDITIONAL_MODULES += --add-module=$(PKG_BUILD_DIR)/lua-nginx
-endif
-
-TARGET_CFLAGS += -ffunction-sections -fdata-sections -DNGX_LUA_NO_BY_LUA_BLOCK
-TARGET_LDFLAGS += -Wl,--gc-sections
TARGET_CFLAGS += -fvisibility=hidden -ffunction-sections -fdata-sections -DNGX_LUA_NO_BY_LUA_BLOCK
TARGET_LDFLAGS += -Wl,--gc-sections
@@ -260,30 +254,10 @@ define Prepare/nginx-naxsi
endef
define Download/lua-nginx
- VERSION:=df5bf1d6242eb5c11adf0dccb8e830dc6672e14b
- SUBDIR:=lua-nginx
- FILE:=lua-nginx-module-$(PKG_VERSION)-$$(VERSION).tar.gz
- URL:=https://github.com/openresty/lua-nginx-module.git
- PROTO:=git
-endef
-
-define Prepare/lua-nginx
- $(eval $(call Download,lua-nginx))
- gzip -dc $(DL_DIR)/$(FILE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS)
- $(call PatchDir,$(PKG_BUILD_DIR),./patches-lua-nginx)
-endef
-
-define Build/Prepare
- $(call Build/Prepare/Default)
- $(if $(CONFIG_NGINX_NAXSI),$(call Prepare/nginx-naxsi))
- $(if $(CONFIG_NGINX_MODULE_LUA),$(call Prepare/lua-nginx))
-endef
-
-define Download/lua-nginx
VERSION:=1967998b0eedab1ff51bff8fafa5fc3db47976aa
SUBDIR:=lua-nginx
FILE:=lua-nginx-module-$(PKG_VERSION)-$$(VERSION).tar.gz
- URL:=git://github.com/openresty/lua-nginx-module.git
+ URL:=https://github.com/openresty/lua-nginx-module.git
PROTO:=git
endef
diff --git a/net/nginx/patches-lua-nginx/100-dont_export_symbols.patch b/net/nginx/patches-lua-nginx/100-dont_export_symbols.patch
deleted file mode 100644
index 8011069ad..000000000
--- a/net/nginx/patches-lua-nginx/100-dont_export_symbols.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- a/lua-nginx/config
-+++ b/lua-nginx/config
-@@ -409,35 +409,35 @@ NGX_ADDON_DEPS="$NGX_ADDON_DEPS \
-
- CFLAGS="$CFLAGS -DNDK_SET_VAR"
-
--ngx_feature="export symbols by default (-E)"
--ngx_feature_libs="-Wl,-E"
--ngx_feature_name=
--ngx_feature_run=no
--ngx_feature_incs="#include <stdio.h>"
--ngx_feature_path=
--ngx_feature_test='printf("hello");'
--
--. auto/feature
--
--if [ $ngx_found = yes ]; then
-- CORE_LIBS="-Wl,-E $CORE_LIBS"
--fi
-+#ngx_feature="export symbols by default (-E)"
-+#ngx_feature_libs="-Wl,-E"
-+#ngx_feature_name=
-+#ngx_feature_run=no
-+#ngx_feature_incs="#include <stdio.h>"
-+#ngx_feature_path=
-+#ngx_feature_test='printf("hello");'
-+#
-+#. auto/feature
-+#
-+#if [ $ngx_found = yes ]; then
-+# CORE_LIBS="-Wl,-E $CORE_LIBS"
-+#fi
-
- # for Cygwin
--ngx_feature="export symbols by default (--export-all-symbols)"
--ngx_feature_libs="-Wl,--export-all-symbols"
--ngx_feature_name=
--ngx_feature_run=no
--ngx_feature_incs="#include <stdio.h>"
--ngx_feature_path=
--ngx_feature_test='printf("hello");'
--
--. auto/feature
--
--if [ $ngx_found = yes ]; then
-- CORE_LIBS="-Wl,--export-all-symbols $CORE_LIBS"
--fi
--
-+#ngx_feature="export symbols by default (--export-all-symbols)"
-+#ngx_feature_libs="-Wl,--export-all-symbols"
-+#ngx_feature_name=
-+#ngx_feature_run=no
-+#ngx_feature_incs="#include <stdio.h>"
-+#ngx_feature_path=
-+#ngx_feature_test='printf("hello");'
-+#
-+#. auto/feature
-+#
-+#if [ $ngx_found = yes ]; then
-+# CORE_LIBS="-Wl,--export-all-symbols $CORE_LIBS"
-+#fi
-+#
- NGX_DTRACE_PROVIDERS="$NGX_DTRACE_PROVIDERS $ngx_addon_dir/dtrace/ngx_lua_provider.d"
- NGX_TAPSET_SRCS="$NGX_TAPSET_SRCS $ngx_addon_dir/tapset/ngx_lua.stp"
-
diff --git a/net/nginx/patches-lua-nginx/101-no_by_lua_block.patch b/net/nginx/patches-lua-nginx/100-no_by_lua_block.patch
index 72d0d9182..fef983fa7 100644
--- a/net/nginx/patches-lua-nginx/101-no_by_lua_block.patch
+++ b/net/nginx/patches-lua-nginx/100-no_by_lua_block.patch
@@ -1,6 +1,6 @@
--- a/lua-nginx/src/ngx_http_lua_module.c
+++ b/lua-nginx/src/ngx_http_lua_module.c
-@@ -148,14 +148,14 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -157,14 +157,14 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
offsetof(ngx_http_lua_loc_conf_t, log_socket_errors),
NULL },
@@ -17,7 +17,7 @@
{ ngx_string("init_by_lua"),
NGX_HTTP_MAIN_CONF|NGX_CONF_TAKE1,
ngx_http_lua_init_by_lua,
-@@ -169,14 +169,14 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -178,14 +178,14 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_MAIN_CONF_OFFSET,
0,
(void *) ngx_http_lua_init_by_file },
@@ -34,7 +34,24 @@
{ ngx_string("init_worker_by_lua"),
NGX_HTTP_MAIN_CONF|NGX_CONF_TAKE1,
ngx_http_lua_init_worker_by_lua,
-@@ -228,7 +228,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -201,6 +201,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+ (void *) ngx_http_lua_init_worker_by_file },
+
+ #if defined(NDK) && NDK
++#ifndef NGX_LUA_NO_BY_LUA_BLOCK
+ /* set_by_lua $res { inline Lua code } [$arg1 [$arg2 [...]]] */
+ { ngx_string("set_by_lua_block"),
+ NGX_HTTP_SRV_CONF|NGX_HTTP_SIF_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
+@@ -209,7 +210,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+ NGX_HTTP_LOC_CONF_OFFSET,
+ 0,
+ (void *) ngx_http_lua_filter_set_by_lua_inline },
+-
++#endif
+ /* set_by_lua $res <inline script> [$arg1 [$arg2 [...]]] */
+ { ngx_string("set_by_lua"),
+ NGX_HTTP_SRV_CONF|NGX_HTTP_SIF_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
+@@ -237,7 +238,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_rewrite_handler_inline },
@@ -43,7 +60,7 @@
/* rewrite_by_lua_block { <inline script> } */
{ ngx_string("rewrite_by_lua_block"),
NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
-@@ -237,7 +237,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -246,7 +247,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_rewrite_handler_inline },
@@ -52,7 +69,7 @@
/* access_by_lua "<inline script>" */
{ ngx_string("access_by_lua"),
NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
-@@ -246,7 +246,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -255,7 +256,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_access_handler_inline },
@@ -61,7 +78,7 @@
/* access_by_lua_block { <inline script> } */
{ ngx_string("access_by_lua_block"),
NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
-@@ -255,7 +255,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -264,7 +265,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_access_handler_inline },
@@ -70,7 +87,7 @@
/* content_by_lua "<inline script>" */
{ ngx_string("content_by_lua"),
NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF|NGX_CONF_TAKE1,
-@@ -263,7 +263,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -272,7 +273,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_content_handler_inline },
@@ -79,7 +96,7 @@
/* content_by_lua_block { <inline script> } */
{ ngx_string("content_by_lua_block"),
NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF|NGX_CONF_BLOCK|NGX_CONF_NOARGS,
-@@ -271,7 +271,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -280,7 +281,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_content_handler_inline },
@@ -88,7 +105,7 @@
/* log_by_lua <inline script> */
{ ngx_string("log_by_lua"),
NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
-@@ -280,7 +280,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -289,7 +290,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_log_handler_inline },
@@ -97,7 +114,7 @@
/* log_by_lua_block { <inline script> } */
{ ngx_string("log_by_lua_block"),
NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
-@@ -289,7 +289,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -298,7 +299,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_log_handler_inline },
@@ -106,7 +123,7 @@
{ ngx_string("rewrite_by_lua_file"),
NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
|NGX_CONF_TAKE1,
-@@ -337,7 +337,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -353,7 +354,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_header_filter_inline },
@@ -115,7 +132,7 @@
/* header_filter_by_lua_block { <inline script> } */
{ ngx_string("header_filter_by_lua_block"),
NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
-@@ -346,7 +346,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -362,7 +363,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_header_filter_inline },
@@ -124,7 +141,7 @@
{ ngx_string("header_filter_by_lua_file"),
NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
|NGX_CONF_TAKE1,
-@@ -362,7 +362,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -378,7 +379,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_body_filter_inline },
@@ -133,7 +150,7 @@
/* body_filter_by_lua_block { <inline script> } */
{ ngx_string("body_filter_by_lua_block"),
NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
-@@ -371,7 +371,7 @@ static ngx_command_t ngx_http_lua_cmds[]
+@@ -387,7 +388,7 @@ static ngx_command_t ngx_http_lua_cmds[]
NGX_HTTP_LOC_CONF_OFFSET,
0,
(void *) ngx_http_lua_body_filter_inline },
@@ -142,3 +159,37 @@
{ ngx_string("body_filter_by_lua_file"),
NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_HTTP_LIF_CONF
|NGX_CONF_TAKE1,
+@@ -395,14 +396,14 @@ static ngx_command_t ngx_http_lua_cmds[]
+ NGX_HTTP_LOC_CONF_OFFSET,
+ 0,
+ (void *) ngx_http_lua_body_filter_file },
+-
++#ifndef NGX_LUA_NO_BY_LUA_BLOCK
+ { ngx_string("balancer_by_lua_block"),
+ NGX_HTTP_UPS_CONF|NGX_CONF_BLOCK|NGX_CONF_NOARGS,
+ ngx_http_lua_balancer_by_lua_block,
+ NGX_HTTP_SRV_CONF_OFFSET,
+ 0,
+ (void *) ngx_http_lua_balancer_handler_inline },
+-
++#endif
+ { ngx_string("balancer_by_lua_file"),
+ NGX_HTTP_UPS_CONF|NGX_CONF_TAKE1,
+ ngx_http_lua_balancer_by_lua,
+@@ -509,14 +510,14 @@ static ngx_command_t ngx_http_lua_cmds[]
+ NGX_HTTP_LOC_CONF_OFFSET,
+ offsetof(ngx_http_lua_loc_conf_t, ssl_ciphers),
+ NULL },
+-
++#ifndef NGX_LUA_NO_BY_LUA_BLOCK
+ { ngx_string("ssl_certificate_by_lua_block"),
+ NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_CONF_BLOCK|NGX_CONF_NOARGS,
+ ngx_http_lua_ssl_cert_by_lua_block,
+ NGX_HTTP_SRV_CONF_OFFSET,
+ 0,
+ (void *) ngx_http_lua_ssl_cert_handler_inline },
+-
++#endif
+ { ngx_string("ssl_certificate_by_lua_file"),
+ NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_CONF_TAKE1,
+ ngx_http_lua_ssl_cert_by_lua,