aboutsummaryrefslogtreecommitdiff
path: root/net/nginx
diff options
context:
space:
mode:
authorAndreas Gnau <andreas.gnau@iopsys.eu>2024-03-06 16:48:45 +0100
committerRosen Penev <rosenp@gmail.com>2024-03-20 11:36:08 -0700
commit3b13b08ad98dd15999e83c98f80674c9965d7a10 (patch)
tree66cd2620fc2f73c1afdc09ecdffbcf127172bb91 /net/nginx
parentd701cae191a4025292b15c6f908b823ad3b88985 (diff)
nginx: Fix compilation with LTO
When CONFIG_USE_LTO=y, the int-size detection script will fail because a variable gets optimised out. Mark it as volatile to fix the issue. Signed-off-by: Andreas Gnau <andreas.gnau@iopsys.eu>
Diffstat (limited to 'net/nginx')
-rw-r--r--net/nginx/Makefile4
-rw-r--r--net/nginx/patches/nginx/102-sizeof_test_fix.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 7509d9575..3d199b962 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
PKG_VERSION:=1.25.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://nginx.org/download/
@@ -23,7 +23,7 @@ PKG_CPE_ID:=cpe:/a:nginx:nginx
PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
-PKG_BUILD_FLAGS:=gc-sections
+PKG_BUILD_FLAGS:=gc-sections lto
# 3rd-party modules
PKG_MOD_EXTRA := \
diff --git a/net/nginx/patches/nginx/102-sizeof_test_fix.patch b/net/nginx/patches/nginx/102-sizeof_test_fix.patch
index 7d2430eab..823e7eabb 100644
--- a/net/nginx/patches/nginx/102-sizeof_test_fix.patch
+++ b/net/nginx/patches/nginx/102-sizeof_test_fix.patch
@@ -4,7 +4,7 @@
$NGX_INCLUDE_INTTYPES_H
$NGX_INCLUDE_AUTO_CONFIG_H
-+char object_code_block[] = {
++volatile char object_code_block[] = {
+ '\n', 'e', '4', 'V', 'A',
+ '0', 'x', ('0' + sizeof($ngx_type)),
+ 'Y', '3', 'p', 'M', '\n'