aboutsummaryrefslogtreecommitdiff
path: root/net/nginx
diff options
context:
space:
mode:
authorJianhui Zhao <zhaojh329@gmail.com>2022-07-27 23:03:19 +0800
committerRosen Penev <rosenp@gmail.com>2022-08-23 22:19:07 -0700
commit33a93e20a6875873232467621624b8b4df8ca427 (patch)
treedb513215d2002be07a17411ba317bd4b1be08b0c /net/nginx
parent3c43f65ae90fd7de6a5bb91d1560917db1b281dd (diff)
nginx: support gzip static mudule
Signed-off-by: Jianhui Zhao <zhaojh329@gmail.com>
Diffstat (limited to 'net/nginx')
-rw-r--r--net/nginx/Config_ssl.in5
-rw-r--r--net/nginx/Makefile4
2 files changed, 9 insertions, 0 deletions
diff --git a/net/nginx/Config_ssl.in b/net/nginx/Config_ssl.in
index 1c53dab6a..df54624d3 100644
--- a/net/nginx/Config_ssl.in
+++ b/net/nginx/Config_ssl.in
@@ -46,6 +46,11 @@ config NGINX_HTTP_GZIP
prompt "Enable HTTP gzip module"
default y
+config NGINX_HTTP_GZIP_STATIC
+ bool
+ prompt "Enable HTTP gzip static module"
+ default y
+
config NGINX_HTTP_SSI
bool
prompt "Enable HTTP ssi module"
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 340de5846..41436aa39 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -31,6 +31,7 @@ PKG_CONFIG_DEPENDS := \
CONFIG_NGINX_STUB_STATUS \
CONFIG_NGINX_HTTP_CHARSET \
CONFIG_NGINX_HTTP_GZIP \
+ CONFIG_NGINX_HTTP_GZIP_STATIC \
CONFIG_NGINX_HTTP_SSI \
CONFIG_NGINX_HTTP_USERID \
CONFIG_NGINX_HTTP_ACCESS \
@@ -152,6 +153,9 @@ ifneq ($(BUILD_VARIANT),all-module)
ifneq ($(CONFIG_NGINX_HTTP_GZIP),y)
ADDITIONAL_MODULES += --without-http_gzip_module
endif
+ ifeq ($(CONFIG_NGINX_HTTP_GZIP_STATIC),y)
+ ADDITIONAL_MODULES += --with-http_gzip_static_module
+ endif
ifneq ($(CONFIG_NGINX_HTTP_SSI),y)
ADDITIONAL_MODULES += --without-http_ssi_module
endif