aboutsummaryrefslogtreecommitdiff
path: root/net/nginx
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2018-08-18 19:11:33 +0200
committerAnsuel Smith <ansuelsmth@gmail.com>2018-08-20 14:55:53 +0200
commit0f21ab63914b1475d1b3cbf004e0cdc4f9c37141 (patch)
tree42f9298365efec225c28dd8fbf35c94d843ae43e /net/nginx
parent77d8472ed57a67bb5f116c6f34b327ac19abc2ef (diff)
nginx: improve luci config
Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'net/nginx')
-rw-r--r--net/nginx/Makefile2
-rw-r--r--net/nginx/files-luci-support/luci_nginx.conf10
-rw-r--r--net/nginx/files-luci-support/luci_nginx_ssl.conf10
-rw-r--r--net/nginx/files-luci-support/luci_uwsgi.conf34
4 files changed, 25 insertions, 31 deletions
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 28c36cb3b..4880f7daf 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
PKG_VERSION:=1.15.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://nginx.org/download/
diff --git a/net/nginx/files-luci-support/luci_nginx.conf b/net/nginx/files-luci-support/luci_nginx.conf
index 53d4ab6c7..8ef6e5944 100644
--- a/net/nginx/files-luci-support/luci_nginx.conf
+++ b/net/nginx/files-luci-support/luci_nginx.conf
@@ -43,13 +43,7 @@ http {
expires 365d;
}
- location / {
- index index.html;
- include luci_uwsgi.conf;
- }
-
- location /luci-static {
-
- }
+ include luci_uwsgi.conf;
+
}
} \ No newline at end of file
diff --git a/net/nginx/files-luci-support/luci_nginx_ssl.conf b/net/nginx/files-luci-support/luci_nginx_ssl.conf
index 4647fecbf..8c8b53d65 100644
--- a/net/nginx/files-luci-support/luci_nginx_ssl.conf
+++ b/net/nginx/files-luci-support/luci_nginx_ssl.conf
@@ -58,13 +58,7 @@ http {
expires 365d;
}
- location / {
- index index.html;
- include luci_uwsgi.conf;
- }
-
- location /luci-static {
-
- }
+ include luci_uwsgi.conf;
+
}
} \ No newline at end of file
diff --git a/net/nginx/files-luci-support/luci_uwsgi.conf b/net/nginx/files-luci-support/luci_uwsgi.conf
index eec66f4ad..6bd1c4223 100644
--- a/net/nginx/files-luci-support/luci_uwsgi.conf
+++ b/net/nginx/files-luci-support/luci_uwsgi.conf
@@ -1,14 +1,20 @@
-uwsgi_param QUERY_STRING $query_string;
-uwsgi_param REQUEST_METHOD $request_method;
-uwsgi_param CONTENT_TYPE $content_type;
-uwsgi_param CONTENT_LENGTH $content_length if_not_empty;
-uwsgi_param REQUEST_URI $request_uri;
-uwsgi_param PATH_INFO $document_uri;
-uwsgi_param SERVER_PROTOCOL $server_protocol;
-uwsgi_param REMOTE_ADDR $remote_addr;
-uwsgi_param REMOTE_PORT $remote_port;
-uwsgi_param SERVER_ADDR $server_addr;
-uwsgi_param SERVER_PORT $server_port;
-uwsgi_param SERVER_NAME $server_name;
-uwsgi_modifier1 9;
-uwsgi_pass unix:////var/run/uwsgi.sock; \ No newline at end of file
+location /cgi-bin/luci {
+ index index.html;
+ uwsgi_param QUERY_STRING $query_string;
+ uwsgi_param REQUEST_METHOD $request_method;
+ uwsgi_param CONTENT_TYPE $content_type;
+ uwsgi_param CONTENT_LENGTH $content_length if_not_empty;
+ uwsgi_param REQUEST_URI $request_uri;
+ uwsgi_param PATH_INFO $document_uri;
+ uwsgi_param SERVER_PROTOCOL $server_protocol;
+ uwsgi_param REMOTE_ADDR $remote_addr;
+ uwsgi_param REMOTE_PORT $remote_port;
+ uwsgi_param SERVER_ADDR $server_addr;
+ uwsgi_param SERVER_PORT $server_port;
+ uwsgi_param SERVER_NAME $server_name;
+ uwsgi_modifier1 9;
+ uwsgi_pass unix:////var/run/uwsgi.sock;
+}
+
+location /luci-static {
+} \ No newline at end of file