aboutsummaryrefslogtreecommitdiff
path: root/net/nfdump/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:27:01 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commite7d9c865036d7bc2ac30604e8573f25ae601aed1 (patch)
tree5efb8a25df387e8e79356447c648ecc3306176b3 /net/nfdump/Makefile
parent35f4ef76e0c88b690ec55f26aed072c4c5989eff (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=lto
See commit 07730ff3 "treewide: add support for "lto" in PKG_BUILD_FLAGS" on the main repository. Note: Some packages only added `-flto` to CFLAGS and not LDFLAGS. This fixes it and properly enables LTO. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'net/nfdump/Makefile')
-rw-r--r--net/nfdump/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/nfdump/Makefile b/net/nfdump/Makefile
index f1879b984..0af7f2ad1 100644
--- a/net/nfdump/Makefile
+++ b/net/nfdump/Makefile
@@ -20,6 +20,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+PKG_BUILD_FLAGS:=lto
include $(INCLUDE_DIR)/package.mk
@@ -39,7 +40,6 @@ define Package/nfdump/conffiles
/etc/config/nfcapd
endef
-TARGET_CFLAGS += -flto
TARGET_LDFLAGS += -Wl,--as-needed $(if $(CONFIG_USE_MUSL),-lfts)
define Package/nfdump/install