aboutsummaryrefslogtreecommitdiff
path: root/net/netifyd/Makefile
diff options
context:
space:
mode:
authorDarryl Sokoloski <darryl@sokoloski.ca>2019-12-09 12:03:25 -0500
committerDarryl Sokoloski <darryl@sokoloski.ca>2019-12-09 12:46:57 -0500
commite94d77119779cb0e98a48d8b31e1763250ce0c18 (patch)
treeac222ad952b28728b00fea8eab9e5e43e73686e4 /net/netifyd/Makefile
parent1d5c3c54451c5e9bf6372d769001e9d55b9c0394 (diff)
netifyd: Updated to v2.98
Maintainer: Darryl Sokoloski / @dsokoloski Compile tested: arm_cortex-a15_neon-vfpv4, TP-Link Archer C2600, master Run tested: TP-Link Archer C2600 Change log for v2.98: [FIX] OpenWrt: Silence ABI warnings. [FIX] Fixed socket buffer dead-lock (pop < 0 bytes). [FIX] Silenced site UUID errors (moved to debug level). [FIX] Updated to SPDX identifier for GPL license. [IMP] Migrated from libjson-c to nlohmann JSON for Modern C++. [IMP] Updated agent status with CPU utilization and sink service status. [IMP] Reformatted sink queue utilization status output. [IMP] Support OS-specific restarting. [IMP] Added payload upload and update frequency control. [IMP] Added MAC addresses to JSON interface list. [IMP] Added option to send established flows to connecting clients. [IMP] Added offline capture processing script. Signed-off-by: Darryl Sokoloski <darryl@sokoloski.ca>
Diffstat (limited to 'net/netifyd/Makefile')
-rw-r--r--net/netifyd/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/net/netifyd/Makefile b/net/netifyd/Makefile
index 2617c19d2..3e60ed97a 100644
--- a/net/netifyd/Makefile
+++ b/net/netifyd/Makefile
@@ -16,10 +16,10 @@ PKG_INSTALL:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://gitlab.com/netify.ai/public/netify-agent.git
-PKG_SOURCE_DATE:=2019-10-21
-PKG_SOURCE_VERSION:=v2.93
-#PKG_SOURCE_VERSION:=4585e2b82c6a34633bc54ac526a635e8a95b28f3
-PKG_MIRROR_HASH:=efbfae112bb4d8d8d22e04ce523484a47b154a4cf57b3992aa28073ba64bd59b
+PKG_SOURCE_DATE:=2019-12-07
+PKG_SOURCE_VERSION:=v2.98
+#PKG_SOURCE_VERSION:=a204805151bc5c35ad09e21913dac25deed13f95
+PKG_MIRROR_HASH:=d235df7f77380e188db75fb885491bf46b2a7a3454f7bf2c85269aeff8f92220
include $(INCLUDE_DIR)/package.mk
@@ -28,7 +28,7 @@ define Package/netifyd
CATEGORY:=Network
TITLE:=Netify Agent
URL:=http://www.netify.ai/
- DEPENDS:=+ca-bundle +libcurl +libmnl +libnetfilter-conntrack +libjson-c +libpcap +zlib +libpthread @!USE_UCLIBC
+ DEPENDS:=+ca-bundle +libcurl +libmnl +libnetfilter-conntrack +libpcap +zlib +libpthread @!USE_UCLIBC
# Explicitly depend on libstdcpp rather than $(CXX_DEPENDS). At the moment
# std::unordered_map is only available via libstdcpp which is required for
# performance reasons.
@@ -47,8 +47,8 @@ define Package/netifyd/conffiles
/etc/netifyd.conf
endef
-TARGET_CFLAGS+=-ffunction-sections -fdata-sections
-TARGET_CXXFLAGS+=-ffunction-sections -fdata-sections
+TARGET_CFLAGS+=-ffunction-sections -fdata-sections -Wno-psabi
+TARGET_CXXFLAGS+=-ffunction-sections -fdata-sections -Wno-psabi
TARGET_LDFLAGS+=-Wl,--gc-sections
CONFIGURE_ARGS+= \