aboutsummaryrefslogtreecommitdiff
path: root/net/netifyd/Makefile
diff options
context:
space:
mode:
authorDarryl Sokoloski <darryl@sokoloski.ca>2022-07-05 15:36:16 -0400
committerRosen Penev <rosenp@gmail.com>2022-07-05 17:37:09 -0700
commit74ea2bdb8084c41a6ef9c082411e9d941d0b3fce (patch)
tree4cde1317dafc469d0bea48c566d3c9d7c1e42e5b /net/netifyd/Makefile
parentc7334faaaaf8afc00ef17776a2565e5ae43c3419 (diff)
netifyd: Updated to v4.2.0.
Signed-off-by: Darryl Sokoloski <darryl@sokoloski.ca>
Diffstat (limited to 'net/netifyd/Makefile')
-rw-r--r--net/netifyd/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/net/netifyd/Makefile b/net/netifyd/Makefile
index a14a6941e..a22c369c3 100644
--- a/net/netifyd/Makefile
+++ b/net/netifyd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2016-2021 eGloo, Incorporated
+# Copyright (C) 2016-2022 eGloo Incorporated
#
# This is free software, licensed under the GNU General Public License v2.
@@ -16,10 +16,10 @@ PKG_INSTALL:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://gitlab.com/netify.ai/public/netify-agent.git
-PKG_SOURCE_DATE:=2021-11-17
-PKG_SOURCE_VERSION:=v3.09
-#PKG_SOURCE_VERSION:=358ec2b0ac321e0608e78c75f6b7434ed1aec326
-PKG_MIRROR_HASH:=660079a75a17a07c638b25dab0ecc972c02fec2124930068bfcf15d28abf4121
+PKG_SOURCE_DATE:=2022-07-04
+PKG_SOURCE_VERSION:=v4.2.0
+#PKG_SOURCE_VERSION:=e3dc824d8f49ddc49a2b392b4960def267a01ba8
+PKG_MIRROR_HASH:=53b98bbc1c9442952c2cd3118de30100da9a366116ad253d14ba990671926a35
include $(INCLUDE_DIR)/package.mk
@@ -49,6 +49,7 @@ define Package/netifyd/conffiles
/etc/netify.d/agent.uuid
/etc/netify.d/serial.uuid
/etc/netify.d/site.uuid
+/etc/netify.d/netify-categories.json
endef
TARGET_CFLAGS+=-ffunction-sections -fdata-sections -Wno-psabi
@@ -59,6 +60,7 @@ CONFIGURE_ARGS+= \
--sharedstatedir=/var/run \
--enable-lean-and-mean \
--disable-libtcmalloc \
+ --disable-jemalloc \
--without-systemdsystemunitdir \
--without-tmpfilesdir
@@ -84,13 +86,12 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/netifyd/pcap-compat/*.h $(1)/usr/include/netifyd/pcap-compat
$(INSTALL_DIR) $(1)/usr/include/netifyd/nlohmann
$(CP) $(PKG_INSTALL_DIR)/usr/include/netifyd/nlohmann/*.hpp $(1)/usr/include/netifyd/nlohmann
- $(INSTALL_DIR) $(1)/usr/include/libndpi-2.9.0
- $(INSTALL_DIR) $(1)/usr/include/libndpi-2.9.0/libndpi
- $(CP) $(PKG_INSTALL_DIR)/usr/include/libndpi-2.9.0/libndpi/*.h $(1)/usr/include/libndpi-2.9.0/libndpi
+ $(INSTALL_DIR) $(1)/usr/include/ndpi
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/ndpi/*.h $(1)/usr/include/ndpi
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetifyd.{a,so*} $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetifyd.{a,so*} $(1)/usr/lib
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnetifyd.pc $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnetifyd.pc $(1)/usr/lib/pkgconfig
endef
define Package/netifyd/install
@@ -103,9 +104,10 @@ define Package/netifyd/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/netifyd $(1)/usr/sbin
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetifyd.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetifyd.so.* $(1)/usr/lib
$(INSTALL_DIR) $(1)/etc/netify.d
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/deploy/netify-sink.conf $(1)/etc/netify.d/netify-sink.conf
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/deploy/netify-apps.conf $(1)/etc/netify.d
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/deploy/netify-categories.json $(1)/etc/netify.d
$(INSTALL_DIR) $(1)/usr/share/netifyd
$(INSTALL_DATA) $(PKG_BUILD_DIR)/deploy/functions.sh $(1)/usr/share/netifyd
endef