aboutsummaryrefslogtreecommitdiff
path: root/net/net-tools/Makefile
diff options
context:
space:
mode:
authorMartin Schiller <ms@dev.tdt.de>2019-12-19 09:02:20 +0100
committerMartin Schiller <ms@dev.tdt.de>2020-01-07 10:27:34 +0100
commitde66af76d639add4f2973d7c130fd17f2d21eb90 (patch)
tree65a4b4e643ecef947a9818b93c618001abe1ee10 /net/net-tools/Makefile
parent5c5f7fa76f9288152960727fbdfee3108ccf323d (diff)
net-tools: add route utility
Extend (and rename) the existing mii-tool package to also support the net-tools route command. This may be needed if you want to support other address families than inet/inet6 like x.25. Also bump to version 2018-11-03. Signed-off-by: Martin Schiller <ms@dev.tdt.de>
Diffstat (limited to 'net/net-tools/Makefile')
-rw-r--r--net/net-tools/Makefile73
1 files changed, 73 insertions, 0 deletions
diff --git a/net/net-tools/Makefile b/net/net-tools/Makefile
new file mode 100644
index 000000000..529045130
--- /dev/null
+++ b/net/net-tools/Makefile
@@ -0,0 +1,73 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2016 Stijn Segers
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=net-tools
+PKG_SOURCE_DATE:=2018-11-03
+PKG_SOURCE_VERSION:=0eebece8c964e3cfa8a018f42b2e7e751a7009a0
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://git.code.sf.net/p/net-tools/code
+PKG_MIRROR_HASH:=9d978b9f8ccae4af623a299155c62d9b3d31213182c785f925bf8704d48a04c9
+
+PKG_MAINTAINER:=Stijn Segers <borromini.reg@protonmail.com>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/mii-tool
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=configure media type using MII commands
+ URL:=http://net-tools.sourceforge.net/
+endef
+
+define Package/mii-tool/description
+ The mii-tool command allows you to set or autodetect the media type
+ or mii chipset-based ethernet devices. It traditionally had been
+ distributed in the net-tools package. This is a single distribution
+ optimized for embedded systems and fully automated cross/-sysroot-builds
+endef
+
+define Package/net-tools-route
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=net-tools - route utility
+ URL:=http://net-tools.sourceforge.net/
+ PROVIDES:=route
+ ALTERNATIVES:=300:/sbin/route:/usr/libexec/net-tools-route
+endef
+
+define Package/net-tools-route/description
+ Replace busybox version of the route command with the full net-tools
+ version. This is normally not needed as busybox is smaller and provides
+ sufficient functionality, but some users may want or need the full
+ functionality of the net-tools variant (e.g. AF_X25).
+endef
+
+define Build/Configure
+ # Failed configure.sh leaves stub config.h around.
+ rm -f $(PKG_BUILD_DIR)/config.h
+ ( cd $(PKG_BUILD_DIR); yes $$$$'\n' | ./configure.sh config.in )
+endef
+
+define Package/mii-tool/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/mii-tool $(1)/usr/sbin/
+endef
+
+define Package/net-tools-route/install
+ $(INSTALL_DIR) $(1)/usr/libexec
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/route $(1)/usr/libexec/net-tools-route
+endef
+
+$(eval $(call BuildPackage,mii-tool))
+$(eval $(call BuildPackage,net-tools-route))