aboutsummaryrefslogtreecommitdiff
path: root/net/mwan3
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2020-11-04 12:07:14 +0100
committerFlorian Eckert <fe@dev.tdt.de>2020-11-06 10:35:55 +0100
commit6834f8e3a6d8f94501500609fda0a82b9a458a19 (patch)
tree295cb41334463ea405ad140e433d1398a190d143 /net/mwan3
parent94a25dbd92adcf070e10a508f5103d6914449f2a (diff)
mwan3: use common makefile install wrappers
With this change you can see at a glance which files will be installed on the system. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'net/mwan3')
-rw-r--r--net/mwan3/Makefile37
-rw-r--r--[-rwxr-xr-x]net/mwan3/files/etc/init.d/mwan30
-rw-r--r--[-rwxr-xr-x]net/mwan3/files/usr/libexec/rpcd/mwan30
-rw-r--r--[-rwxr-xr-x]net/mwan3/files/usr/sbin/mwan30
-rw-r--r--[-rwxr-xr-x]net/mwan3/files/usr/sbin/mwan3rtmon0
-rw-r--r--[-rwxr-xr-x]net/mwan3/files/usr/sbin/mwan3track0
6 files changed, 36 insertions, 1 deletions
diff --git a/net/mwan3/Makefile b/net/mwan3/Makefile
index 99990e4cc..c603397da 100644
--- a/net/mwan3/Makefile
+++ b/net/mwan3/Makefile
@@ -67,8 +67,43 @@ define Build/Compile
endef
define Package/mwan3/install
- $(CP) ./files/* $(1)
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/etc/config/mwan3 \
+ $(1)/etc/config/
+
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/etc/hotplug.d/iface/15-mwan3 \
+ $(1)/etc/hotplug.d/iface/
+ $(INSTALL_DATA) ./files/etc/hotplug.d/iface/16-mwan3-user \
+ $(1)/etc/hotplug.d/iface/
+
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/etc/init.d/mwan3 \
+ $(1)/etc/init.d/
+
+ $(INSTALL_DIR) $(1)/lib/mwan3
+ $(INSTALL_DATA) ./files/lib/mwan3/common.sh \
+ $(1)/lib/mwan3/
+ $(INSTALL_DATA) ./files/lib/mwan3/mwan3.sh \
+ $(1)/lib/mwan3/
+
+ $(INSTALL_DIR) $(1)/usr/libexec/rpcd
+ $(INSTALL_BIN) ./files/usr/libexec/rpcd/mwan3 \
+ $(1)/usr/libexec/rpcd/
+
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) ./files/usr/sbin/mwan3 \
+ $(1)/usr/sbin/
+ $(INSTALL_BIN) ./files/usr/sbin/mwan3rtmon \
+ $(1)/usr/sbin/
+ $(INSTALL_BIN) ./files/usr/sbin/mwan3track \
+ $(1)/usr/sbin/
+
$(CP) $(PKG_BUILD_DIR)/libwrap_mwan3_sockopt.so.1.0 $(1)/lib/mwan3/
+
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_DATA) ./files/etc/uci-defaults/mwan3-migrate-flush_conntrack \
+ $(1)/etc/uci-defaults/
endef
$(eval $(call BuildPackage,mwan3))
diff --git a/net/mwan3/files/etc/init.d/mwan3 b/net/mwan3/files/etc/init.d/mwan3
index b7cf91eb1..b7cf91eb1 100755..100644
--- a/net/mwan3/files/etc/init.d/mwan3
+++ b/net/mwan3/files/etc/init.d/mwan3
diff --git a/net/mwan3/files/usr/libexec/rpcd/mwan3 b/net/mwan3/files/usr/libexec/rpcd/mwan3
index a97b33d5c..a97b33d5c 100755..100644
--- a/net/mwan3/files/usr/libexec/rpcd/mwan3
+++ b/net/mwan3/files/usr/libexec/rpcd/mwan3
diff --git a/net/mwan3/files/usr/sbin/mwan3 b/net/mwan3/files/usr/sbin/mwan3
index 45776bdfc..45776bdfc 100755..100644
--- a/net/mwan3/files/usr/sbin/mwan3
+++ b/net/mwan3/files/usr/sbin/mwan3
diff --git a/net/mwan3/files/usr/sbin/mwan3rtmon b/net/mwan3/files/usr/sbin/mwan3rtmon
index 569b4d172..569b4d172 100755..100644
--- a/net/mwan3/files/usr/sbin/mwan3rtmon
+++ b/net/mwan3/files/usr/sbin/mwan3rtmon
diff --git a/net/mwan3/files/usr/sbin/mwan3track b/net/mwan3/files/usr/sbin/mwan3track
index d4a5f44ab..d4a5f44ab 100755..100644
--- a/net/mwan3/files/usr/sbin/mwan3track
+++ b/net/mwan3/files/usr/sbin/mwan3track