aboutsummaryrefslogtreecommitdiff
path: root/net/mwan3
diff options
context:
space:
mode:
authorAdze1502 <jeroen.louwes@gmail.com>2014-12-22 08:44:41 +0100
committerAdze1502 <jeroen.louwes@gmail.com>2014-12-22 08:44:41 +0100
commit1ff50d94dc6071d946d68ec7bceaece86e4be9c3 (patch)
tree65addd93cdddd6479703f42856fb5ddecb01edd5 /net/mwan3
parent95d3737aaafdaadb1e606439a7da374ca1f2d6c8 (diff)
mwan3: update to version 1.5-9
Fix issue where config file would be overwritten in some cases Fix issue where local address of wan point-to-point links were unreachable from lan Signed-off-by: Jeroen Louwes <jeroen.louwes@gmail.com>
Diffstat (limited to 'net/mwan3')
2 files changed, 7 insertions, 3 deletions
diff --git a/net/mwan3/Makefile b/net/mwan3/Makefile
index 7839ce207..121952756 100644
--- a/net/mwan3/Makefile
+++ b/net/mwan3/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mwan3
PKG_VERSION:=1.5
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_MAINTAINER:=Jeroen Louwes <jeroen.louwes@gmail.com>
PKG_LICENSE:=GPLv2
@@ -32,14 +32,14 @@ interfaces, connection tracking and an easy to manage traffic ruleset.
endef
define Package/mwan3/conffiles
- /etc/config/mwan3
+/etc/config/mwan3
endef
define Build/Compile
endef
define Package/mwan3/install
- $(CP) ./files/* $(1)
+$(CP) ./files/* $(1)
endef
$(eval $(call BuildPackage,mwan3))
diff --git a/net/mwan3/files/etc/hotplug.d/iface/15-mwan3 b/net/mwan3/files/etc/hotplug.d/iface/15-mwan3
index ea00bd05f..d4f4bf004 100644
--- a/net/mwan3/files/etc/hotplug.d/iface/15-mwan3
+++ b/net/mwan3/files/etc/hotplug.d/iface/15-mwan3
@@ -71,6 +71,10 @@ mwan3_set_connected_iptables()
$IPT -A mwan3_connected -d $connected_networks -j MARK --set-xmark 0xff00/0xff00
done
+ for connected_networks in $($IP route list table 0 | awk '{print $2}' | egrep '[0-9]{1,3}(\.[0-9]{1,3}){3}'); do
+ $IPT -A mwan3_connected -d $connected_networks -j MARK --set-xmark 0xff00/0xff00
+ done
+
$IPT -I mwan3_connected -d 224.0.0.0/3 -j MARK --set-xmark 0xff00/0xff00
$IPT -I mwan3_connected -d 127.0.0.0/8 -j MARK --set-xmark 0xff00/0xff00
fi