aboutsummaryrefslogtreecommitdiff
path: root/net/mtr
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-01-16 02:27:09 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-01-16 02:53:08 +0000
commitf68ce32f9b46664b04f9defe1542afc01aee1327 (patch)
tree550babeee1e88e2ef6ed9d71588cbd6be7728c45 /net/mtr
parentd82cc22019f8e31cf1417497c2ff038f0c642650 (diff)
mtr: fix UNKNOWN version reporting
Supersedes openwrt/packages#7634 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net/mtr')
-rw-r--r--net/mtr/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/net/mtr/Makefile b/net/mtr/Makefile
index 67921de4c..6743e190b 100644
--- a/net/mtr/Makefile
+++ b/net/mtr/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mtr
PKG_VERSION:=0.92
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.bitwizard.nl/mtr/files
@@ -26,6 +26,16 @@ PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
+# Creation of .tarball-version is an attempt to make it explicit to configure
+# script the program version. See discussions at link [1] for more details
+#
+# [1] mtr: add autoreconf, https://github.com/openwrt/packages/pull/6962#issuecomment-419156300
+#
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ echo "$(PKG_VERSION)" >$(PKG_BUILD_DIR)/.tarball-version
+endef
+
define Package/mtr
SECTION:=net
CATEGORY:=Network