aboutsummaryrefslogtreecommitdiff
path: root/net/mtr
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-06-30 17:32:03 +0200
committerJo-Philipp Wich <jow@openwrt.org>2015-06-30 17:32:03 +0200
commitf17dd769f1a6aa0b2c9f4fc20c389720f41f89c8 (patch)
treec41276c12f3a609f3d9f2003cf15303c288b8b8a /net/mtr
parent9bf03cb1f50be079bc33d869d0d9c8b268ae6c88 (diff)
mtr: fix build with globally disabled IPv6
The current mtr does not build if IPv6 is disabled globally, add a patch to fix the build in this case. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'net/mtr')
-rw-r--r--net/mtr/Makefile2
-rw-r--r--net/mtr/patches/100-disabled-ipv6-fix.patch49
2 files changed, 50 insertions, 1 deletions
diff --git a/net/mtr/Makefile b/net/mtr/Makefile
index 1a4660111..f3ca9bacf 100644
--- a/net/mtr/Makefile
+++ b/net/mtr/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mtr
PKG_REV:=dd2b750
PKG_VERSION:=0.85+newdns-$(PKG_REV)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/traviscross/mtr.git
diff --git a/net/mtr/patches/100-disabled-ipv6-fix.patch b/net/mtr/patches/100-disabled-ipv6-fix.patch
new file mode 100644
index 000000000..5ef9984ff
--- /dev/null
+++ b/net/mtr/patches/100-disabled-ipv6-fix.patch
@@ -0,0 +1,49 @@
+--- a/net.c
++++ b/net.c
+@@ -307,9 +307,11 @@ void net_send_tcp(int index)
+ struct sockaddr_storage local;
+ struct sockaddr_storage remote;
+ struct sockaddr_in *local4 = (struct sockaddr_in *) &local;
+- struct sockaddr_in6 *local6 = (struct sockaddr_in6 *) &local;
+ struct sockaddr_in *remote4 = (struct sockaddr_in *) &remote;
++#ifdef ENABLE_IPV6
++ struct sockaddr_in6 *local6 = (struct sockaddr_in6 *) &local;
+ struct sockaddr_in6 *remote6 = (struct sockaddr_in6 *) &remote;
++#endif
+ socklen_t len;
+
+ ttl = index + 1;
+@@ -566,8 +568,10 @@ void net_send_query(int index)
+
+ /* sendto() assumes packet length includes the IPv4 header but not the
+ IPv6 header. */
+- spacketsize = abs(packetsize) -
+- ( ( af == AF_INET ) ? 0 : sizeof (struct ip6_hdr) );
++ spacketsize = abs(packetsize);
++#ifdef ENABLE_IPV6
++ spacketsize -= ( ( af == AF_INET ) ? 0 : sizeof (struct ip6_hdr) );
++#endif
+ rv = sendto(sendsock, packet, spacketsize, 0, remotesockaddr, salen);
+ if (first && (rv < 0) && ((errno == EINVAL) || (errno == EMSGSIZE))) {
+ /* Try the first packet again using host byte order. */
+--- a/dns.c
++++ b/dns.c
+@@ -49,7 +49,7 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ //#include <ctype.h>
+-//#include <string.h>
++#include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <signal.h>
+--- a/net.h
++++ b/net.h
+@@ -20,6 +20,7 @@
+ #include <netdb.h>
+ #include <arpa/inet.h>
+ #include <netinet/in.h>
++#include <sys/select.h>
+ #include <sys/socket.h>
+ #ifdef ENABLE_IPV6
+ #include <netinet/ip6.h>