aboutsummaryrefslogtreecommitdiff
path: root/net/mtr
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:09:13 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commit35f4ef76e0c88b690ec55f26aed072c4c5989eff (patch)
treec5b36bb3b16488c4546c3c283b8a6020e3966143 /net/mtr
parent565866a47210c9711c29173052063779b6d3bcfc (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=gc-sections
See commit da370098 "treewide: add support for "gc-sections" in PKG_BUILD_FLAGS" on the main repository. Note: This only touches packages which use all three parts (-ffunction-sections, -fdata-sections and -Wl,--gc-sections) enabled by this build flag. Some packages only use a subset, and these are left unchanged for now. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'net/mtr')
-rw-r--r--net/mtr/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/mtr/Makefile b/net/mtr/Makefile
index 5e20e4faa..a340898ce 100644
--- a/net/mtr/Makefile
+++ b/net/mtr/Makefile
@@ -23,6 +23,7 @@ PKG_CPE_ID:=cpe:/a:matt_kimball_and_roger_wolff:mtr
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
+PKG_BUILD_FLAGS:=gc-sections
CONFIGURE_ARGS += \
--without-gtk \
@@ -68,8 +69,7 @@ define Package/mtr/description
running statistics about each machine.
endef
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
+TARGET_LDFLAGS += -Wl,--as-needed
CONFIGURE_VARS += ac_cv_lib_cap_cap_set_proc=no