aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto
diff options
context:
space:
mode:
authorThomas Huehn <thomas@net.t-labs.tu-berlin.de>2017-01-12 16:10:32 +0100
committerKarl Palsson <karlp@etactica.com>2017-01-12 16:17:53 +0000
commite0da6bf5bb7aad2e903ae3d8e092772662aa567a (patch)
tree229e18111edb60871b68ca850738d7f97a63bd4b /net/mosquitto
parent462219ca74b5026222d01c2e9f9c4fed84c793be (diff)
mosquitto: Fix host UNAME detection
This fixes a bug when mosquitto is crosscompiled in LEDE on OS X. UNAME is explicitly executed on the host, when we want it to be treated as a regular linux build. This patch passes the proper UNAME=Linux variable to the mosquitto make file in order to respect linux as cross-compiler. Signed-off-by: Thomas Huehn <thomas@net.t-labs.tu-berlin.de> Reviewed-by: Karl Palsson <karlp@tweak.net.au>
Diffstat (limited to 'net/mosquitto')
-rw-r--r--net/mosquitto/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 08c037dc1..94a0298c1 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -209,7 +209,7 @@ define Package/libmosquittopp/install
endef
# Applies to all...
-MAKE_FLAGS += WITH_DOCS=no
+MAKE_FLAGS += WITH_DOCS=no UNAME=Linux
ifeq ($(BUILD_VARIANT),nossl)
MAKE_FLAGS += WITH_TLS=no WITH_WEBSOCKETS=no
else