aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2017-01-17 10:43:42 +0000
committerKarl Palsson <karlp@etactica.com>2017-01-17 17:06:42 +0000
commita52eee16d8fc779f29fef859a15fc11686224450 (patch)
treef08af63da95bc6b467071a4994148794c366281f /net/mosquitto
parentb4f0cdedcfc9d5606450314a8c98bdf123096b2f (diff)
net/mosquitto: add PROVIDES to daemon and library
Adding PROVIDES to both the daemon and library and -nossl variants allow downstream packages to simply declare a single dependency. mosquitto-client however, still needs to explicitly depend on the ssl or nossl variant however. Signed-off-by: Karl Palsson <karlp@etactica.com>
Diffstat (limited to 'net/mosquitto')
-rw-r--r--net/mosquitto/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 94a0298c1..c8484fe19 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mosquitto
PKG_VERSION:=1.4.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.txt
@@ -36,12 +36,14 @@ define Package/$(PKG_NAME)
TITLE+= (with SSL support)
DEPENDS+= +libopenssl +MOSQUITTO_LWS:libwebsockets-openssl
VARIANT:=ssl
+ PROVIDES:=mosquitto
endef
define Package/$(PKG_NAME)-nossl
$(call Package/$(PKG_NAME)/default)
TITLE+= (without SSL support)
VARIANT:=nossl
+ PROVIDES:=mosquitto
endef
define Package/$(PKG_NAME)/config
@@ -105,6 +107,7 @@ define Package/libmosquitto/default
CATEGORY:=Libraries
DEPENDS:=+libpthread +librt +libcares
TITLE:= mosquitto - client library
+ PROVIDES:=libmosquitto
endef
define Package/libmosquitto