aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2017-04-05 14:01:59 +0000
committerKarl Palsson <karlp@etactica.com>2017-05-05 11:36:37 +0000
commit338252f9eb72f72274157c24878621be095a21f4 (patch)
tree4bc1e74a093df22b3ee6c042c0b369f9e48e07ff /net/mosquitto
parent56db76945e1bbc6fae8548582fe9cf44c95f1420 (diff)
net/mosquito: bump to 1.4.11
Full changelog available at: https://mosquitto.org/2017/02/version-1-4-11-released/ Mostly ipv6 and websockets fixes, but requires a patch (submitted upstream) to work around an accidental glibc dependency upstream. Signed-off-by: Karl Palsson <karlp@etactica.com>
Diffstat (limited to 'net/mosquitto')
-rw-r--r--net/mosquitto/Makefile4
-rw-r--r--net/mosquitto/patches/01-fix-libanl-musl.patch28
2 files changed, 30 insertions, 2 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index ee8a62050..10e51b632 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mosquitto
-PKG_VERSION:=1.4.10
+PKG_VERSION:=1.4.11
PKG_RELEASE:=2
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.txt
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://mosquitto.org/files/source/
-PKG_MD5SUM:=61839b47b58c5799aab76584f13ed66f
+PKG_HASH:=ca47533bbc1b7c5e15d6e5d96d3efc59677f2515b6692263c34b7c48f33280c5
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
diff --git a/net/mosquitto/patches/01-fix-libanl-musl.patch b/net/mosquitto/patches/01-fix-libanl-musl.patch
new file mode 100644
index 000000000..b49721702
--- /dev/null
+++ b/net/mosquitto/patches/01-fix-libanl-musl.patch
@@ -0,0 +1,28 @@
+commit f095176610597c8e95481a400375a742f2e96a3a
+Author: Karl Palsson <karlp@etactica.com>
+Date: Fri May 5 09:57:37 2017 +0000
+
+ [344] Only link libanl when WITH_ADNS=yes
+
+ Removes the hard link of libanl for Linux, leaving the protected link
+ when WITH_ADNS is specified.
+
+ Fixes: 433ee5c4d6852b507b43eae9c9a2c9028c6b48e5
+
+ Signed-off-by: Karl Palsson <karlp@etactica.com>
+
+diff --git a/config.mk b/config.mk
+index 6e369c2..44639d2 100644
+--- a/config.mk
++++ b/config.mk
+@@ -159,10 +159,6 @@ ifeq ($(UNAME),QNX)
+ LIB_LIBS:=$(LIB_LIBS) -lsocket
+ endif
+
+-ifeq ($(UNAME),Linux)
+- BROKER_LIBS:=$(BROKER_LIBS) -lanl
+-endif
+-
+ ifeq ($(WITH_WRAP),yes)
+ BROKER_LIBS:=$(BROKER_LIBS) -lwrap
+ BROKER_CFLAGS:=$(BROKER_CFLAGS) -DWITH_WRAP