aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2018-05-03 11:26:13 +0000
committerKarl Palsson <karlp@etactica.com>2018-05-07 11:09:14 +0000
commit276ce75a96595f752909dcba2b66fd789aad0e55 (patch)
tree06181605b57ed864dfbed50f0c9ad303fe2e6f17 /net/mosquitto
parentf73f39eed1a1e45ec39a78a3b0266238f3c5e434 (diff)
mosquitto: bump to major 1.5 release
This is a major release. https://mosquitto.org/blog/2018/05/version-1-5-released/ Performance, configurability, protection from fuzzing and bad data, customizable SSL contexts, all sorts of goodies. Signed-off-by: Karl Palsson <karlp@etactica.com>
Diffstat (limited to 'net/mosquitto')
-rw-r--r--net/mosquitto/Makefile4
-rw-r--r--net/mosquitto/patches/100-remove-build-timestamps.patch56
2 files changed, 2 insertions, 58 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 2713f5dd1..51bb1870e 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mosquitto
-PKG_VERSION:=1.4.15
+PKG_VERSION:=1.5
PKG_RELEASE:=3
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.txt
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://mosquitto.org/files/source/
-PKG_HASH:=7d3b3e245a3b4ec94b05678c8199c806359737949f4cfe0bf936184f6ca89a83
+PKG_HASH:=80c9606a906c736fe582b67bdfb650ee45239fea058fe34927f81277d3486e21
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
diff --git a/net/mosquitto/patches/100-remove-build-timestamps.patch b/net/mosquitto/patches/100-remove-build-timestamps.patch
deleted file mode 100644
index 7dadcf738..000000000
--- a/net/mosquitto/patches/100-remove-build-timestamps.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff --git a/config.mk b/config.mk
-index bfaa208..2a3e2bf 100644
---- a/config.mk
-+++ b/config.mk
-@@ -87,7 +87,6 @@ WITH_SOCKS:=yes
- # Also bump lib/mosquitto.h, CMakeLists.txt,
- # installer/mosquitto.nsi, installer/mosquitto-cygwin.nsi
- VERSION=1.4.15
--TIMESTAMP:=$(shell date "+%F %T%z")
-
- # Client library SO version. Bump if incompatible API/ABI changes are made.
- SOVERSION=1
-@@ -115,7 +114,7 @@ LIB_CFLAGS:=${CFLAGS} ${CPPFLAGS} -I. -I.. -I../lib
- LIB_CXXFLAGS:=$(LIB_CFLAGS) ${CPPFLAGS}
- LIB_LDFLAGS:=${LDFLAGS}
-
--BROKER_CFLAGS:=${LIB_CFLAGS} ${CPPFLAGS} -DVERSION="\"${VERSION}\"" -DTIMESTAMP="\"${TIMESTAMP}\"" -DWITH_BROKER
-+BROKER_CFLAGS:=${LIB_CFLAGS} ${CPPFLAGS} -DVERSION="\"${VERSION}\"" -DWITH_BROKER
- CLIENT_CFLAGS:=${CFLAGS} ${CPPFLAGS} -I../lib -DVERSION="\"${VERSION}\""
-
- ifneq ($(or $(findstring $(UNAME),FreeBSD), $(findstring $(UNAME),OpenBSD)),)
-diff --git a/src/conf.c b/src/conf.c
-index 25d80a6..9ab0599 100644
---- a/src/conf.c
-+++ b/src/conf.c
-@@ -338,7 +338,7 @@ void mqtt3_config_cleanup(struct mqtt3_config *config)
-
- static void print_usage(void)
- {
-- printf("mosquitto version %s (build date %s)\n\n", VERSION, TIMESTAMP);
-+ printf("mosquitto version %s\n\n", VERSION);
- printf("mosquitto is an MQTT v3.1.1/v3.1 broker.\n\n");
- printf("Usage: mosquitto [-c config_file] [-d] [-h] [-p port]\n\n");
- printf(" -c : specify the broker config file.\n");
-diff --git a/src/mosquitto.c b/src/mosquitto.c
-index 22b6372..b581f45 100644
---- a/src/mosquitto.c
-+++ b/src/mosquitto.c
-@@ -291,7 +291,7 @@ int main(int argc, char *argv[])
- rc = 1;
- return rc;
- }
-- _mosquitto_log_printf(NULL, MOSQ_LOG_INFO, "mosquitto version %s (build date %s) starting", VERSION, TIMESTAMP);
-+ _mosquitto_log_printf(NULL, MOSQ_LOG_INFO, "mosquitto version %s starting", VERSION);
- if(int_db.config_file){
- _mosquitto_log_printf(NULL, MOSQ_LOG_INFO, "Config loaded from %s.", int_db.config_file);
- }else{
-@@ -308,8 +308,6 @@ int main(int argc, char *argv[])
- /* Set static $SYS messages */
- snprintf(buf, 1024, "mosquitto version %s", VERSION);
- mqtt3_db_messages_easy_queue(&int_db, NULL, "$SYS/broker/version", 2, strlen(buf), buf, 1);
-- snprintf(buf, 1024, "%s", TIMESTAMP);
-- mqtt3_db_messages_easy_queue(&int_db, NULL, "$SYS/broker/timestamp", 2, strlen(buf), buf, 1);
- }
- #endif
-