aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2018-02-19 11:35:41 +0000
committerKarl Palsson <karlp@etactica.com>2018-02-19 12:04:47 +0000
commit055be639b385029a7540ec22cc926392c7ca1dde (patch)
tree71652ea0dc4f462604892e68122aa05cee4a1e98 /net/mosquitto
parenta0855d59fd16513fcf3c061a49164803b1f0a1aa (diff)
mosquitto: auto-disable TLS-PSK support if not available
OpenSSL grew the ability to turn off TLS-PSK support. Make sure that mosquitto turns on/off TLS-PSK support based on this OpenSSL config. Fixes https://github.com/openwrt/packages/issues/5633 Signed-off-by: Karl Palsson <karlp@etactica.com>
Diffstat (limited to 'net/mosquitto')
-rw-r--r--net/mosquitto/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 189ac5a14..667057014 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -60,7 +60,8 @@ endef
define Package/mosquitto-ssl/description
$(call Package/mosquitto/default/description)
- This package is built with SSL support
+This package is built with SSL support. TLS-PSK will be included (in both
+the client and broker) if OpenSSL is built with TLS-PSK support.
endef
define Package/mosquitto-nossl/description
@@ -218,6 +219,7 @@ ifeq ($(BUILD_VARIANT),nossl)
MAKE_FLAGS += WITH_TLS=no WITH_WEBSOCKETS=no
else
MAKE_FLAGS += WITH_WEBSOCKETS=$(if $(CONFIG_MOSQUITTO_LWS),"yes","no")
+ MAKE_FLAGS += WITH_TLS_PSK=$(if $(CONFIG_OPENSSL_WITH_PSK),"yes","no")
endif
$(eval $(call BuildPackage,mosquitto-ssl))