aboutsummaryrefslogtreecommitdiff
path: root/net/mosh
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-12-13 21:54:01 -0800
committerRosen Penev <rosenp@gmail.com>2019-12-14 00:18:53 -0800
commit3bfbb7d1dba923ebc3d54431bccf16b3b06ea297 (patch)
treed4d81ff494e6cdaa04c264d3decf31be53d06a34 /net/mosh
parent77a1b3ba60c930b2378a71451e6652da2f37b53a (diff)
mosh: Fix compilation with libcxx
Partial backport of upstream patch.`` Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/mosh')
-rw-r--r--net/mosh/Makefile2
-rw-r--r--net/mosh/patches/020-std.patch10
2 files changed, 11 insertions, 1 deletions
diff --git a/net/mosh/Makefile b/net/mosh/Makefile
index c22041f16..b4a666b87 100644
--- a/net/mosh/Makefile
+++ b/net/mosh/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mosh
PKG_VERSION:=1.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://mosh.org/
diff --git a/net/mosh/patches/020-std.patch b/net/mosh/patches/020-std.patch
new file mode 100644
index 000000000..06ad284c7
--- /dev/null
+++ b/net/mosh/patches/020-std.patch
@@ -0,0 +1,10 @@
+--- a/src/network/network.cc
++++ b/src/network/network.cc
+@@ -60,7 +60,6 @@
+ #define AI_NUMERICSERV 0
+ #endif
+
+-using namespace std;
+ using namespace Network;
+ using namespace Crypto;
+