aboutsummaryrefslogtreecommitdiff
path: root/net/miniupnpd/Makefile
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2023-08-25 17:59:22 +0000
committerStan Grishin <stangri@melmac.ca>2023-08-25 17:59:22 +0000
commit4c934aea718ceb682551b9bab0a8618e4b12920d (patch)
tree92b6f61f3325e8aa57e916901ff62e73bb59ae5d /net/miniupnpd/Makefile
parent83f60a6ee74184cbd30e49f96c08f993e7e71eca (diff)
miniupnpd: remove uci-defaults and fw4-include files for nftables variant
* remove firewall4.include file as it is not needed and procuces a firewall error on service miniupnpd restart * remove the uci-defaults file as its sole purpose was to install the firewall include file * modify the Makefile to reflect the deleted files Signed-off-by: Stan Grishin <stangri@melmac.ca>
Diffstat (limited to 'net/miniupnpd/Makefile')
-rw-r--r--net/miniupnpd/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index 6373f309c..1526e922c 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=miniupnpd
PKG_VERSION:=2.3.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -109,10 +109,6 @@ endef
define Package/miniupnpd-nftables/install
$(call Package/miniupnpd/install/Default,$1)
- $(INSTALL_DIR) $(1)/etc/uci-defaults
- $(INSTALL_DIR) $(1)/usr/share/miniupnpd
- $(INSTALL_BIN) ./files/miniupnpd.defaults.nftables $(1)/etc/uci-defaults/99-miniupnpd
- $(INSTALL_DATA) ./files/firewall4.include $(1)/usr/share/miniupnpd/firewall.include
$(INSTALL_DIR) $(1)/usr/share/nftables.d
$(CP) ./files/nftables.d/* $(1)/usr/share/nftables.d/
endef