aboutsummaryrefslogtreecommitdiff
path: root/net/miniupnpd/Makefile
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-05-08 18:11:16 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-05-09 20:02:17 +0100
commit2777953325b67b349a809ddbf17b0bd8c9e62b3a (patch)
tree118afdf5dbde3bf43f01852d088e23e4b83c950f /net/miniupnpd/Makefile
parent0cb460a2a7c6b208babb47af70ab63f37e17a269 (diff)
miniupnpd: build with gc-sections & LTO
Building with --gc-sections & -flto drop ipk size from 72600 to 66345 on MIPS No misbehaviour due to these optimisations observed. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'net/miniupnpd/Makefile')
-rw-r--r--net/miniupnpd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index f7e3c39bc..ba9929418 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=miniupnpd
PKG_VERSION:=2.0.20180503
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=http://miniupnp.free.fr/files
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -39,6 +39,8 @@ define Build/Prepare
echo "$(VERSION_NUMBER)" | tr '() ' '_' >$(PKG_BUILD_DIR)/os.openwrt
endef
+TARGET_CFLAGS += -flto -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -flto -Wl,--gc-sections
MAKE_FLAGS += \
TARGET_OPENWRT=1 TEST=0 LIBS="" \
CC="$(TARGET_CC) -DIPTABLES_143 -lip4tc -luuid \