aboutsummaryrefslogtreecommitdiff
path: root/net/miniupnpd/Makefile
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2022-04-22 17:19:51 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2022-04-22 17:20:39 +0200
commit0bc25077b37d74065fd107dc9f85fbb11ccba56b (patch)
tree3f39ac9a839e03fd56a07cb81fbd65021c696d92 /net/miniupnpd/Makefile
parent0248058f6ba0ab1aad8a6c816354486067e5e521 (diff)
Revert "miniupnpd: bump to latest git source"
This was reverted because the commit does more things than just "bump to latest git source". Also, it was not properly reviewed/tested. See: https://github.com/openwrt/packages/pull/18133#issuecomment-1106346788 This reverts commit b3b911e99238282a768bce962bc2a271f84229ac. Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'net/miniupnpd/Makefile')
-rw-r--r--net/miniupnpd/Makefile18
1 files changed, 4 insertions, 14 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index 45950ccc9..2a1372755 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -8,15 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=miniupnpd
-PKG_VERSION:=2.3.0
+PKG_VERSION:=2.2.3
PKG_RELEASE:=$(AUTORELEASE)
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/miniupnp/miniupnp.git
-PKG_SOURCE_DATE:=2022-03-20
-PKG_SOURCE_VERSION:=fda61180e07abd222623e54b9239557bbffbc21d
-PKG_MIRROR_HASH:=f81a5b920f1bddb5673a2455461d4dca20d17138f5488713c5a759f2a64e9f18
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)/miniupnpd
+PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_HASH:=f89c310ce9575183af3fec61af65e548f85114133df8caaaa9e204c13b7a9da5
PKG_MAINTAINER:=
PKG_LICENSE:=BSD-3-Clause
@@ -29,9 +26,6 @@ PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/version.mk
-TAR_OPTIONS+= --strip-components 1
-TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
-
define Package/miniupnpd/Default
SECTION:=net
CATEGORY:=Network
@@ -115,10 +109,6 @@ endef
define Package/miniupnpd-nftables/install
$(call Package/miniupnpd/install/Default,$1)
- $(INSTALL_DIR) $(1)/usr/share/miniupnpd
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/miniupnpd/miniupnpd_functions.sh $(1)/usr/share/miniupnpd/miniupnpd_functions.sh
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/miniupnpd/nft_init.sh $(1)/usr/share/miniupnpd/nft_init.sh
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/miniupnpd/nft_removeall.sh $(1)/usr/share/miniupnpd/nft_removeall.sh
endef
$(eval $(call BuildPackage,miniupnpd-iptables))