aboutsummaryrefslogtreecommitdiff
path: root/net/mini_snmpd
diff options
context:
space:
mode:
authorMarcel Telka <marcel@telka.sk>2019-07-18 22:59:52 +0200
committerMarcel Telka <marcel@telka.sk>2019-07-18 23:05:36 +0200
commitea4f242a6be302292dd0a62348e44074a7a80b1b (patch)
tree3b20cb0fbc0add4e40b92e7cfb2826d2f0e2de79 /net/mini_snmpd
parentc8734591ca2d2c9e69a69591ccd1365795826689 (diff)
mini_snmpd: Allow up to 8 network interfaces
This changes the init script to allow to monitor up to 8 network interfaces. The support for up to 8 network interfaces was added to mini_snmpd release 1.3 in November 2015. Signed-off-by: Marcel Telka <marcel@telka.sk>
Diffstat (limited to 'net/mini_snmpd')
-rw-r--r--net/mini_snmpd/Makefile2
-rw-r--r--net/mini_snmpd/files/mini_snmpd.init2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/mini_snmpd/Makefile b/net/mini_snmpd/Makefile
index bce9d9125..a5470d53d 100644
--- a/net/mini_snmpd/Makefile
+++ b/net/mini_snmpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mini_snmpd
PKG_VERSION:=1.4-rc1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_MAINTAINER:=Marcin Jurkowski <marcin1j@gmail.com>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
diff --git a/net/mini_snmpd/files/mini_snmpd.init b/net/mini_snmpd/files/mini_snmpd.init
index 9e6eff88e..96dc5ab9e 100644
--- a/net/mini_snmpd/files/mini_snmpd.init
+++ b/net/mini_snmpd/files/mini_snmpd.init
@@ -77,7 +77,7 @@ append_interface() {
# for the purposes of snmp monitoring it doesn't need to be up, it just needs to exist in /proc/net/dev
network_get_device netdev "$name"
if [ -n "$netdev" ] && grep -qF "$netdev" /proc/net/dev ]; then
- [ $netdev_count -ge 4 ] && {
+ [ $netdev_count -ge 8 ] && {
_err "$cfg: too many network interfaces configured, ignoring $name"
return
}