aboutsummaryrefslogtreecommitdiff
path: root/net/mini_snmpd/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-13 01:00:20 +0800
committerJeffery To <jeffery.to@gmail.com>2019-10-13 02:01:34 +0800
commit53e1692ae91b1b5fc59a7e8ab7fb98f8775eb4b6 (patch)
tree49a758e5d65104f3f86247868009c5774d39e04b /net/mini_snmpd/Makefile
parent7de37d7fea41a285c57a9593612548cd8b509ec0 (diff)
treewide: Use default PKG_BUILD_DIR when possible
This removes lines that set PKG_BUILD_DIR when the set value is no different from the default value. Specifically, the line is removed if the assigned value is: * $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION) The default PKG_BUILD_DIR was updated[1] to incorporate BUILD_VARIANT if it is set, so now this is identical to the default value. * $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR) if PKG_SOURCE_SUBDIR is set to $(PKG_NAME)-$(PKG_VERSION), making it the same as the previous case * $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) This is the same as the default PKG_BUILD_DIR when there is no BUILD_VARIANT. * $(BUILD_DIR)/[name]-$(PKG_VERSION) where [name] is a string that is identical to PKG_NAME [1]: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=e545fac8d968864a965edb9e50c6f90940b0a6c9 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'net/mini_snmpd/Makefile')
-rw-r--r--net/mini_snmpd/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/net/mini_snmpd/Makefile b/net/mini_snmpd/Makefile
index a5470d53d..a40ba7e95 100644
--- a/net/mini_snmpd/Makefile
+++ b/net/mini_snmpd/Makefile
@@ -22,7 +22,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_MIRROR_HASH:=175d4d9b69c3195ef850eaffd8ac63d012a052089b4a9d074b4d3aef96888b8f
PKG_FIXUP:=autoreconf
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
# As warned by upstream maintainer and binutils