aboutsummaryrefslogtreecommitdiff
path: root/net/microsocks
diff options
context:
space:
mode:
authorOzan Göktan <ozan@goktan.site>2024-03-10 14:39:46 +0100
committerTianling Shen <cnsztl@gmail.com>2024-03-21 14:51:58 +0800
commit544e4a90619bc6bf39a6845d8e5b7b3c0b2e160a (patch)
tree92fe292ae0de68a5cf37ab5573ba3d82461e437c /net/microsocks
parent8742b6c340ec4b82efd99d07f58fdb816f3dc107 (diff)
microsocks: update to 1.0.4
Signed-off-by: Ozan Göktan <ozan@goktan.site>
Diffstat (limited to 'net/microsocks')
-rw-r--r--net/microsocks/Makefile4
-rw-r--r--net/microsocks/files/microsocks.config1
-rwxr-xr-xnet/microsocks/files/microsocks.init3
3 files changed, 6 insertions, 2 deletions
diff --git a/net/microsocks/Makefile b/net/microsocks/Makefile
index 82abec56a..79eea2e6a 100644
--- a/net/microsocks/Makefile
+++ b/net/microsocks/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=microsocks
-PKG_VERSION:=1.0.3
+PKG_VERSION:=1.0.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/rofl0r/microsocks/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=6801559b6f8e17240ed8eef17a36eea8643412b5a7476980fd4e24b02a021b82
+PKG_HASH:=130127a87f55870f18fbe47a64d9b9533020e2900802d36a0f6fd2b074313deb
PKG_MAINTAINER:=Mateusz Korniak <matkorgithubcom@ant.gliwice.pl>
PKG_LICENSE:=MIT
diff --git a/net/microsocks/files/microsocks.config b/net/microsocks/files/microsocks.config
index b85d74084..d834a7aac 100644
--- a/net/microsocks/files/microsocks.config
+++ b/net/microsocks/files/microsocks.config
@@ -7,3 +7,4 @@ config microsocks 'config'
option user ''
option password ''
option auth_once '0' # Boolean, must be used together with user/pass
+ option quiet '1'
diff --git a/net/microsocks/files/microsocks.init b/net/microsocks/files/microsocks.init
index e775d89d7..74dc03ff5 100755
--- a/net/microsocks/files/microsocks.init
+++ b/net/microsocks/files/microsocks.init
@@ -18,6 +18,7 @@ start_service() {
local _user
local _format
local _auth_once
+ local _quiet
config_get _port "config" "port"
config_get _listenip "config" "listenip"
@@ -25,6 +26,7 @@ start_service() {
config_get _user "config" "user"
config_get _password "config" "password"
config_get_bool _auth_once "config" "auth_once" 0
+ config_get_bool _quiet "config" "quiet" 0
procd_open_instance "$CONF"
procd_set_param command /usr/bin/microsocks
@@ -34,6 +36,7 @@ start_service() {
[ -z "$_user" ] || procd_append_param command -u "${_user}"
[ -z "$_password" ] || procd_append_param command -P "${_password}"
[ "$_auth_once" -eq "0" ] || procd_append_param command -1
+ [ "$_quiet" -eq "0" ] || procd_append_param command -q
procd_set_param respawn
procd_set_param stderr 1