aboutsummaryrefslogtreecommitdiff
path: root/net/microsocks/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:27:01 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commite7d9c865036d7bc2ac30604e8573f25ae601aed1 (patch)
tree5efb8a25df387e8e79356447c648ecc3306176b3 /net/microsocks/Makefile
parent35f4ef76e0c88b690ec55f26aed072c4c5989eff (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=lto
See commit 07730ff3 "treewide: add support for "lto" in PKG_BUILD_FLAGS" on the main repository. Note: Some packages only added `-flto` to CFLAGS and not LDFLAGS. This fixes it and properly enables LTO. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'net/microsocks/Makefile')
-rw-r--r--net/microsocks/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/microsocks/Makefile b/net/microsocks/Makefile
index e16e577b3..82abec56a 100644
--- a/net/microsocks/Makefile
+++ b/net/microsocks/Makefile
@@ -12,6 +12,8 @@ PKG_MAINTAINER:=Mateusz Korniak <matkorgithubcom@ant.gliwice.pl>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
+PKG_BUILD_FLAGS:=lto
+
include $(INCLUDE_DIR)/package.mk
define Package/microsocks
@@ -30,8 +32,7 @@ define Package/microsocks/conffiles
/etc/config/microsocks
endef
-TARGET_CFLAGS+= -flto
-TARGET_LDFLAGS+= -flto -Wl,--gc-sections,--as-needed
+TARGET_LDFLAGS+= -Wl,--gc-sections,--as-needed
define Package/microsocks/install
$(INSTALL_DIR) $(1)/usr/bin