aboutsummaryrefslogtreecommitdiff
path: root/net/mdnsresponder/Makefile
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2015-12-19 18:55:19 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2015-12-19 18:55:22 +0200
commitf1b88fd69e97c6d5c3c2b3e64d6d1ce481fe879a (patch)
tree72543c7a7d02875d5fe1cdc8ef9ecd8443c8594c /net/mdnsresponder/Makefile
parentc1dc8cd0e4c3ea65b8859cac8a54ef4a7c702d81 (diff)
mdnsresponder: (fix build) use TARGET_CC as LD
Probably related to -fstack-protector being used. Got the idea from: http://ubuntuforums.org/showthread.php?t=352642&p=10100263#post10100263 Regarding the missing __stack_check_fail_local, using gcc as the linker instead of ld fixes the issue without disabling stack protection as with -fno-stack-protector. Fixes linker errs on some targets: objects/prod/dnssd_clientstub.c.so.o: In function `handle_resolve_response': dnssd_clientstub.c:(.text+0x395): undefined reference to `__stack_chk_fail_local' objects/prod/dnssd_clientstub.c.so.o: In function `handle_query_response': dnssd_clientstub.c:(.text+0x4bd): undefined reference to `__stack_chk_fail_local' Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'net/mdnsresponder/Makefile')
-rw-r--r--net/mdnsresponder/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/mdnsresponder/Makefile b/net/mdnsresponder/Makefile
index cfc552701..0536a4032 100644
--- a/net/mdnsresponder/Makefile
+++ b/net/mdnsresponder/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mDNSResponder
PKG_VERSION:=567
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://opensource.apple.com/tarballs/mDNSResponder/
@@ -85,6 +85,7 @@ endef
# I have no idea why -lc is required, but without it, C library symbols are
# not found:
MAKE_FLAGS += \
+ LD="$(TARGET_CC)" \
CFLAGS_DEBUG="$(TARGET_CFLAGS)" \
LINKOPTS=-lc \
LDCONFIG= \