aboutsummaryrefslogtreecommitdiff
path: root/net/mac-telnet/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:09:13 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commit35f4ef76e0c88b690ec55f26aed072c4c5989eff (patch)
treec5b36bb3b16488c4546c3c283b8a6020e3966143 /net/mac-telnet/Makefile
parent565866a47210c9711c29173052063779b6d3bcfc (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=gc-sections
See commit da370098 "treewide: add support for "gc-sections" in PKG_BUILD_FLAGS" on the main repository. Note: This only touches packages which use all three parts (-ffunction-sections, -fdata-sections and -Wl,--gc-sections) enabled by this build flag. Some packages only use a subset, and these are left unchanged for now. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'net/mac-telnet/Makefile')
-rw-r--r--net/mac-telnet/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/mac-telnet/Makefile b/net/mac-telnet/Makefile
index 0e4e4c1b9..93b8d7c0b 100644
--- a/net/mac-telnet/Makefile
+++ b/net/mac-telnet/Makefile
@@ -13,13 +13,14 @@ PKG_SOURCE_DATE:=2015-09-02
PKG_SOURCE_VERSION:=37d83cbc9c07266d6c957d27bf75285b305eceab
PKG_MIRROR_HASH:=ed414f3fb08f1e2bb4313d00fb99327df697de7c60284fe588fc7eb3769adb7a
+PKG_BUILD_FLAGS:=gc-sections
+
PKG_LICENSE:=GPL-2.0-or-later
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
include $(INCLUDE_DIR)/package.mk
-TARGET_CFLAGS += -ffunction-sections -fdata-sections $(if $(CONFIG_MACTELNET_PLAIN_SUPPORT),-DTELNET_SUPPORT)
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += $(if $(CONFIG_MACTELNET_PLAIN_SUPPORT),-DTELNET_SUPPORT)
# 1: name
# 2: executable