aboutsummaryrefslogtreecommitdiff
path: root/net/lynx
diff options
context:
space:
mode:
authorLeonid Esman <leonid.esman@gmail.com>2019-01-09 00:02:18 +0300
committerLeonid Esman <leonid.esman@gmail.com>2019-01-09 00:02:18 +0300
commit887182dce94e3ca3903abb49a50a37dd344d7b79 (patch)
tree574942c1d3c72ef8b8b3f3b34125dcd24e61d580 /net/lynx
parent3004241558a4236e660d93451321148f743c9bf3 (diff)
lynx: initial commit
Based on https://github.com/kyak/openwrt-packages/tree/master/lynx Tested on TP-Link TL-MR3020 v3 Signed-off-by: Leonid Esman <leonid.esman@gmail.com>
Diffstat (limited to 'net/lynx')
-rw-r--r--net/lynx/Makefile65
-rw-r--r--net/lynx/files/lynx.cfg7
-rw-r--r--net/lynx/files/lynx.lss115
3 files changed, 187 insertions, 0 deletions
diff --git a/net/lynx/Makefile b/net/lynx/Makefile
new file mode 100644
index 000000000..0a9c14e4d
--- /dev/null
+++ b/net/lynx/Makefile
@@ -0,0 +1,65 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+# Based on https://github.com/kyak/openwrt-packages/tree/master/lynx
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lynx
+PKG_VERSION:=2.8.9rel.1
+PKG_RELEASE:=1
+
+PKG_LICENSE:=GPL-2.0
+PKG_MAINTAINER:=
+PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://invisible-mirror.net/archives/lynx/tarballs/
+PKG_HASH:=387f193d7792f9cfada14c60b0e5c0bff18f227d9257a39483e14fa1aaf79595
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)$(PKG_VERSION)
+# try current development version
+# URL for current development version - http://invisible-island.net/datafiles/release/lynx-cur.tar.bz2
+
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lynx
+ TITLE:=Lynx is the text web browser
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libncursesw +zlib +libopenssl +ca-bundle
+ URL:=http://lynx.invisible-island.net/
+endef
+
+define Package/lynx/description
+ Classic non-graphical (text-mode) web browser
+endef
+
+# customize as you need
+CONFIGURE_ARGS += --with-zlib --with-ssl \
+ --enable-ipv6 \
+ --with-screen=ncursesw \
+ --enable-widec \
+ --enable-locale-charset \
+ --enable-charset-choice \
+ --enable-cjk \
+ --enable-japanese-utf8 \
+ --enable-nsl-fork \
+ --disable-config-info --disable-echo \
+ --disable-dired --disable-trace \
+ --disable-finger --disable-gopher --disable-news --disable-wais \
+ --disable-prettysrc --disable-scrollbar --disable-gzip-help \
+ --disable-idna --disable-syslog --disable-font-switch
+
+CONFIGURE_VARS += cf_cv_ncurses_header="ncursesw/curses.h" \
+ ac_cv_path_NCURSES_CONFIG=""
+
+define Package/lynx/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/etc
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/lynx $(1)/usr/bin/
+ $(INSTALL_DATA) ./files/lynx.cfg $(1)/etc/
+ $(INSTALL_DATA) ./files/lynx.lss $(1)/etc/
+endef
+
+$(eval $(call BuildPackage,lynx))
+
diff --git a/net/lynx/files/lynx.cfg b/net/lynx/files/lynx.cfg
new file mode 100644
index 000000000..062b22a5a
--- /dev/null
+++ b/net/lynx/files/lynx.cfg
@@ -0,0 +1,7 @@
+#
+LOCALE_CHARSET:TRUE
+#
+#http_proxy:http://some.server.dom:port/
+#https_proxy:http://some.server.dom:port/
+#no_proxy:host.domain.dom
+
diff --git a/net/lynx/files/lynx.lss b/net/lynx/files/lynx.lss
new file mode 100644
index 000000000..2d02eb181
--- /dev/null
+++ b/net/lynx/files/lynx.lss
@@ -0,0 +1,115 @@
+# Setting the normal and default types lets us keep (almost) the same colors
+# whether the terminal's default colors are white-on-black or black-on-white.
+# It is not exact since the default "white" is not necessarily the same color
+# as the ANSI lightgray, but is as close as we can get in a standard way.
+#
+# If you really want the terminal's default colors, and if lynx is built using
+# ncurses' default-color support, remove these two lines:
+normal: normal: lightgray:black
+default: normal: white:black
+
+# Normal type styles correspond to HTML tags.
+#
+# The next line (beginning with "em") means: use bold if mono, otherwise
+# brightblue on <defaultbackground>
+em: bold: brightblue
+strong: bold: brightred
+b: bold: red
+i: bold: brightblue
+a: bold: green
+img: dim: brown
+fig: normal: gray
+caption: reverse: brown
+hr: normal: yellow
+blockquote: normal: brightblue
+ul: normal: brown
+address: normal: magenta
+title: normal: magenta
+tt: dim: brightmagenta: black
+h1: bold: yellow: blue
+label: normal: magenta
+q: normal: yellow: magenta
+small: dim: default
+big: bold: yellow
+sup: bold: yellow
+sub: dim: gray
+li: normal: magenta
+code: normal: cyan
+cite: normal: cyan
+
+table: normal: brightcyan
+tr: bold: brown
+td: normal: default
+br: normal: default
+
+# Special styles - not corresponding directly to HTML tags
+# alert - status bar, when message begins "Alert".
+# alink - active link
+# normal - default attributes
+# status - status bar
+# whereis - whereis search target
+#
+#normal:normal:default:blue
+alink: reverse: yellow: black
+status: reverse: yellow: blue
+alert: bold: yellow: red
+whereis: reverse+underline: magenta: cyan
+# currently not used
+#value:normal:green
+
+menu.bg: normal: black: lightgray
+menu.frame: normal: black: lightgray
+menu.entry: normal: lightgray: black
+menu.n: normal: red: gray
+menu.active: normal: yellow: black
+menu.sb: normal: brightred: lightgray
+
+forwbackw.arrow:reverse
+hot.paste: normal: brightred: gray
+
+# Styles with classes - <ul class=red> etc.
+ul.red: underline: brightred
+ul.blue: bold: brightblue
+li.red: reverse: red: yellow
+li.blue: bold: blue
+strong.a: bold: black: red
+em.a: reverse: black: blue
+strong.b: bold: white: red
+em.b: reverse: white: blue
+strong.debug: reverse: green
+font.letter: normal: white: blue
+input.submit: normal: cyan
+tr.baone: bold: yellow
+tr.batwo: bold: green
+tr.bathree: bold: red
+#
+# Special handling for link.
+link: normal: white
+link.green: bold: brightgreen
+link.red: bold: black: red
+link.blue: bold: white: blue
+link.toc: bold: black: white
+# Special cases for link - the rel or title is appended after the class.
+# <link rel=next class=red href="1">
+link.red.next: bold: red
+link.red.prev: bold: yellow: red
+link.blue.prev: bold: yellow: blue
+link.blue.next: bold: blue
+link.green.toc: bold: white: green
+#
+# Define styles that will be used when syntax highlighting is requested
+# (commandline option -prettysrc).
+span.htmlsrc_comment:normal: white
+span.htmlsrc_tag:normal: white
+#If you don't like that the tag name and attribute name are displayed
+#in different colors, comment the following line.
+span.htmlsrc_attrib:normal: cyan
+span.htmlsrc_attrval:normal: magenta
+span.htmlsrc_abracket:normal: white
+span.htmlsrc_entity:normal: white
+##span.htmlsrc_href:
+##span.htmlsrc_entire:
+span.htmlsrc_badseq:normal: red
+span.htmlsrc_badtag:normal: red
+span.htmlsrc_badattr:normal: red
+span.htmlsrc_sgmlspecial:normal: yellow