aboutsummaryrefslogtreecommitdiff
path: root/net/lora-gateway-hal/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-06-20 13:25:59 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-06-21 09:52:32 +0800
commit9ac5ac81ab2241b7c13c01e8801e0e7d95ebb4eb (patch)
tree8e917b35332bcae8517d6291258d80f0d44d4b46 /net/lora-gateway-hal/Makefile
parent274b111782c1d7650ae244a16e141e39d339af32 (diff)
treewide: avoid deref symlinks when installing .so
This change is inspired by commit openwrt/openwrt@38b22b1e ("nghttp2: deduplicate files in libnghttp2") The packages in this commit are identified with the following command grep -rin -E 'INSTALL_(DATA|BIN)' | grep -F '.so' | grep -F '*' Some of them do not have symlinks and are not affected, but the change is still applied for consideration of best practices just in case Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net/lora-gateway-hal/Makefile')
-rw-r--r--net/lora-gateway-hal/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/lora-gateway-hal/Makefile b/net/lora-gateway-hal/Makefile
index d71d18165..80e802b17 100644
--- a/net/lora-gateway-hal/Makefile
+++ b/net/lora-gateway-hal/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lora-gateway-hal
PKG_VERSION:=5.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://codeload.github.com/Lora-net/lora_gateway/tar.gz/v$(PKG_VERSION)?
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -64,7 +64,7 @@ define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/libloragw/inc/loragw_* $(1)/usr/include/libloragw
$(CP) $(PKG_BUILD_DIR)/libloragw/config.h $(1)/usr/include/libloragw
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/libloragw/libloragw.so* $(1)/usr/lib/
+ $(CP) $(PKG_BUILD_DIR)/libloragw/libloragw.so* $(1)/usr/lib/
$(LN) libloragw.so.0 $(1)/usr/lib/libloragw.so
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_BUILD_DIR)/loragw.pc $(1)/usr/lib/pkgconfig/
@@ -72,7 +72,7 @@ endef
define Package/libloragw/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/libloragw/libloragw.so.* $(1)/usr/lib/
+ $(CP) $(PKG_BUILD_DIR)/libloragw/libloragw.so.* $(1)/usr/lib/
endef
define Package/libloragw-tests/install